Forum Discussion

mduo74's avatar
mduo74
Frequent Visitor
2 years ago

BigQuery service account through gateway - Invalid connection credentials

Hi,

I want to authenticate to BQ using a service account and using Gateway.
When I create a Cloud connection the credentials work. 

When I create On premise Gateway connection with same credentials I get error - "Unable to update connection credentials. Invalid connection credentials." 

Any Ideas what to check?

Thank you

2 Replies

  • hackcrr's avatar
    hackcrr
    Icon for Memorable Member rankMemorable Member

    Hi, mduo74 

    I think you can refer to the following article to learn how to connect Google BigQuery in Power BI Service

    https://www.cdata.com/kb/tech/bigquery-cloud-powerbi-service.rst

    https://learn.microsoft.com/en-us/power-query/connectors/google-bigquery

    https://www.youtube.com/watch?v=wqWXv_CFjj8

    You encountered the "Unable to update connection credentials. Invalid Connection Credentials" error, you can check if the following are the causes:

    1. The service account has the correct permissions
    2. Ensure that you have correctly copied and pasted the contents of the JSON key file for the service account. For local data gateways, you may need to convert the JSON key to a format acceptable to the gateway
    3. ensure that the server or computer on which the Local Data Gateway resides has access to the BigQuery API. check any firewall rules or network policies to ensure that they do not prevent the gateway from communicating with BigQuery.
    4. Check the local data gateway's error logs for more detailed information about the problem

     

     

    Best Regards,

    hackcrr

    If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

  • mduo74's avatar
    mduo74
    Frequent Visitor

    Hi, 

    the points 1 and 2 I have correct as I check the exact same credentials without using the On Premise Data Gateway and they work. 

    For the format acceptable for the Gateway are there some special requirements to them? I did not find any. As they are both Microsoft original I hope it must be compatible.


    I check the logs and I do not see anything related to Service account there. 

    Best