Forum Discussion
Automatic Refresh fails from PBI Service but PBI Desktop refresh works
Can some one please help me.
I have a report that has been working for over 10 months now. Automatic refresh is set up and running.
Database: 2 On Premise SQL servers
Gateway: Azure On-Premises Data Gateway
I woke up one day and find that the report refresh has failed. All efforts to troubleshoot has proven fruitless.
This is the error I get when I try to refresh. on PBI service.
However, refreshing on PBI desktop and re-publishing works just fine. I believe if there is a circular dependency as indicated in the error, the PBI desktop refresh should not work. Also, no change was made on this report or the dataset before this error popped up. It just started one day.
This is a daily financial report that goes out to the top executives in the company and I have had to manually refresh on PBI desktop and re-publish every morning before the report is sent out but this is not sustainable.
Can someone please help out?
This has been fixed although I can't still explain why the error came about and how the solution fixed it.
Solution: Added a new gateway connectionGo to Semantic model --> Schedule refresh -->> Gateway and cloud connections --> Add to Gateway
In the new window, I filled all required info as it was a new connection.
After that refreshed my dataset it worked.
This is weird because the old gateway connection is there and still works for other reports connecting to the same DB using the same on-premise gateway
2 Replies
- CelebrityITProNew Member
Additional info: I created a duplicate of the report on PBI desktop. Published it and still refresh does not work on PBI service
- CelebrityITProNew Member
This has been fixed although I can't still explain why the error came about and how the solution fixed it.
Solution: Added a new gateway connectionGo to Semantic model --> Schedule refresh -->> Gateway and cloud connections --> Add to Gateway
In the new window, I filled all required info as it was a new connection.
After that refreshed my dataset it worked.
This is weird because the old gateway connection is there and still works for other reports connecting to the same DB using the same on-premise gateway