Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
Anonymous
Not applicable

Applications Not Appearing as Available for End Users

Hey there, 

 

Seem to have an issue with my applications loading up within the APPs section of Power BI Service. 

Accessing this area through Google Chrome results in a blank page. 

 

Take a look at this screenshot. Capture.PNG

 

The page is blank and no application are loaded. 

 

Right now my work around for end-users are to enable all the applications as "FEATURED" so they appear on the featured part of the homescreen within Power BI. 

 

The applications also load up through Microsoft Teams - by using the Power BI App there. Users can see applications. 

 

Any ideas on what this might be? 

Thanks Much! 

1 ACCEPTED SOLUTION
hvnter
Resolver I
Resolver I

@Anonymous ,
When I cleared my browser cache, I was able to see my Apps again

View solution in original post

11 REPLIES 11
ategally
Frequent Visitor

Its a known issue to the Power BI Team and a fix will be implemented on 4th october 2021.   In the meantime use the List View and failing this open Power BI service in different browser/in-private mode.

Anonymous
Not applicable

If you change view option, in my case from Gallery to List, all apps appears i have tried Chrome and Edge both works. Must be some bug but at least some way around

syerly
New Member

This did not solve for my end users...Also switching the view from Gallery to list and back must be done each time you exit an app or load the PBI service for each end user. 

If you select List View and close it down it will remain on List View.  Try opening Power BI service in different browser/in-private mode.  Worked for me.  Product team are working on it and issue fix will be deployed by 4th Oct till that time product team asked me to use List View option.

ategally
Frequent Visitor

We have the same issue and no one in the organisation can view any Apps.  Clearing cache or logging out doesn't work.

Switching from list to gallery a few times has magically made the apps appear again!

 

syerly
New Member

Same issue. Cleared cache - didn't work

hvnter
Resolver I
Resolver I

@Anonymous ,
When I cleared my browser cache, I was able to see my Apps again

GilbertQ
Super User
Super User

Hi @Anonymous 

 

If this appears to be an issue, could you log out of the Power BI Service and log back in and see if that works?

 

If it still does not work then I would suggest logging a support ticket https://powerbi.microsoft.com/en-us/support/pro/





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

AntonioPalomas
Advocate III
Advocate III

I have the same problem with many users.

If you select List View and close it down it will remain on List View.  Try opening Power BI service in different browser/in-private mode.  Worked for me.  Product team are working on it and issue fix will be deployed by 4th Oct till that time product team asked me to use List View option.

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Fabric Monthly Update - May 2024

Check out the May 2024 Fabric update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors