Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
AMD0791
Advocate II
Advocate II

App users can't view reports(new issue this week)

I have an app that has been published for the whole organization and has been in place working great for months.  

 

Monday this week, users started getting the "Can't display visual" error for all the visuals on the report.  However, the users who are added to the workspace can see the report just fine.  The "see details" is the usual pile of useless GUID's.

 

AMD0791_1-1686174238554.png

This report is built on a dataset auto-generated from a datamart.  The datamart is refreshing as expected (but it does seem to have an internal error when I try to update the structure - but I *think* that's a different problem)

 

Things I tried:

1. Republishing the app - fail

2. Changing the audience on the app from Entire Organization to a fairly large AD group which would capture most users.   No luck

3. Changing the audience on the app to a specific user just for testing.  Fail

4. I noticed that the "Manage Permissions" page for the datamart listed all the users and groups that I had added to the App at some point, but the "Manage Permissions" page for the actual report only lists the workspace users.  This seems to be consistent with other apps that are working fine, so I didn't make much of it.

5.  On a lark, I tried adding my test user to the REPORT's "Manage Permissions" page.  After that, the test user could view the report.

6. I removed the test user from the report permissions, and it still worked. I removed the test user from the datamart permissions and it still worked.

7.  I changed the app audience back to "Entire Organization".  Test user still works.

8. Asked helpful human tester and they still get the errors.

 

So all the permissions are basically back to where they started.  My test user that didn't work at first now works even though they've been removed from everything and the app permissions are back to "Entire Organization", but my helpful human test user still can't see the report.  It seems like adding the test user on the report permissions page did something that stuck even after removing them, but I have no idea what.

 

I really hate trying to figure out Power BI permissions.  The potential lag is unpredictable -- some things are immediate, some may take a while.

 

Anyone else seeing issues or have ideas what's going on here?

0 REPLIES 0

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.