Forum Discussion
All reports are stuck at refreshing status
all the reports are stuck at refreshing status for a long time. We have to cancel them manually.
After we cancel the refresh of all reports, we still cannot refresh report successfully. The refresh successful after we restart the gateway.
Is there anyone who have this issue before or how to check what is the root cause for this?
I restart the gateway and I can refresh successfully now. But I don't know why. I got an error message from the gateway log " MashupException encountered while accessing the target data source"
6 Replies
- aj1973
Community Champion
- JosieGuo
Helper I
can you explain more? Because this issue is resolved by restarting gateway. I want to find the root cause for this issue to avoid it happen again.
- aj1973
Community Champion
You can build your report to monitor your gateway
https://learn.microsoft.com/en-us/data-integration/gateway/service-gateway-performance
There's a template that you can use.
- chris__1
Advocate II
I am currently observing the same problem with our semantic models: Manual and scheduled updates are never completed and remain in “In Progress” status for hours. Canceling and restarting does not help!
- JosieGuo
Helper I
I restart the gateway and I can refresh successfully now. But I don't know why. I got an error message from the gateway log " MashupException encountered while accessing the target data source"
- AnonymousNot applicable
Hi JosieGuo ,
Sometimes, network connectivity problems can cause this error and also ensure that the gateway is properly configured and up to date
You may check the privacy levels for your data sources. In Power BI Desktop, go to File > Options and settings > Data source settings, and ensure that the privacy levels are set to “Organizational” or “Public” as needed.
MashupException encountered while accessing the target data source“ The error might be related to the mashup engine used by Power BI. The credentials used to access the data source are updated and have the necessary permissions. re-entering the credentials in the gateway settings can resolve the issue.Best regards.
Community Support Team_Caitlyn