Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
vizerik
Regular Visitor

Adding a SharePoint data source with a service principal

Hi,

 

I am trying to access files located in SharePoint Online. We would like to use a service principal for the authentication. But when I try to save the credentials I get the following error:

 

Service principal error
 
Unable to update connection credentials.
Invalid connection credentials.
 
Details:
 
The credentials provided for the SharePoint source are invalid. (Source at https://mytenant.sharepoint.com/sites/MySite.)

 

This is what I enter in the data source

 

sharePointSiteURL: https://mytenant.sharepoint.com/sites/MySite

Authentication method: Service principal

Tenant ID: My tenant ID

Service Principle ID: The Application (client) ID from the Entra ID App registration

Service principle key: The value of the secret I created for the Entra ID App registration

 

The Entra ID App registration has the following API permissions

vizerik_0-1711449344152.png

 

The service principal (Entra ID app) has Read permissions on the SharePoint site

vizerik_1-1711445661684.png

What is it I am missing in order to get this to work 🙂 ?

 

Regards Erik

11 REPLIES 11
zema84
New Member

Hello,

did you find a solution for this ? I habe now the same issue with the same error message. I tried also to create a Ticket but it was closed with the message Microsoft has no ressources and i sould contact a partner.

Hi,

 

No, unfortunately no resolution yet. The case I have with Microsoft is still open.

Mariza
New Member

Did you find a solution to this? I'm facing the same issue

Hi Mariza,

 

No, unfortunately I have not found a solution to this 😞

 

If you have managed to get it working, I would be happy to hear what I need to do.

Still no news? This problem is getting really annoying.

Hi,

 

No, not yet.

 

I still have an open support ticket with Microsoft regarding this.

 

I do not know if it will result in a resolution yet. But I will update this thread once the case is closed.

zhangjoe
Employee
Employee

 

Service Principle ID: The Application (client) ID from the Entra ID App registration, 
You need Object ID for the SP ID. Not Application ID. 

 

Hi @zhangjoe,

 

When we change from Application (client) ID to Object ID we got another error:

 

vizerik_0-1712068682834.png

Any idea what might cause this?

v-rongtiep-msft
Community Support
Community Support

Hi @vizerik ,

Have submitted this issue internal to confirm, would update here as soon as possible if there is any update about it.

 

Best Regards
Community Support Team _ Rongtie

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-rongtiep-msft  - We are facing a similar issue when trying to connect to a Sharepoint Online list from PowerBI Online using service principal as the authentication method. Wondering if you have got any guidance from your internal team 

Hi @v-rongtiep-msft,

 

Thank you for getting back to me!

 

It would be appreciated if you could come back to me no matter what info you get in the internal ticket you created.

 

I guess it could be an issue with Power BI.

 

But it could also be that there is something I have done wrong. If that is the case I would like some guidance on what I have to do in order to get it to work.

 

Just for your information. I found the below thread which sounds like a similiar issue I have.

 

https://community.fabric.microsoft.com/t5/Developer/SharePoint-data-source-authentication-method-ser...

 

Regards Erik

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors