Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
Anonymous
Not applicable

A Power BI report shared works for some and not others

Hi,

We have created a Power BI report, which is in Power BI service and shared it to some users. The problem is that some of the users which have no license can view the dashboard while others can't. There seems to be no RLS defined. When those users click on the report link the report page comes up but the slicers and visualizations give an error message of "Couldn't load the data for this Visual". I don't understand why this is happening only for some and why not all? How can we solve this?

 

Thanks in advance

1 ACCEPTED SOLUTION
Anonymous
Not applicable

I guess I solved it and it was because of an access issue. Just had to gave workspace access to it

View solution in original post

2 REPLIES 2
Anonymous
Not applicable

I guess I solved it and it was because of an access issue. Just had to gave workspace access to it

pratyashasamal
Super User
Super User

Hi @Anonymous ,
You can refer to these links for your issue .

Couldn't load the data for this visual

I think your dataset has RLS, right?
If this is a case, you need to assign role to user to apply RLS filter, otherwise they will got this can't load data error.

Row-level security (RLS) with Power BI

BTW, current RLS only works on read permission, so admin and dataset owner can see each records even if they not get RLS roles.

Service: "Couldn't load the data for this visual", Desktop: all fine

The issue was the date in this function. replacing 31.01. by 31/01 solved the issue.

Couldn't load the data for this visual

The problem was that I had finished my SQL query with semicolon;

When I removed the semicolon from the SQL query in advanced editor, the issue was resolved

Couldn't load data for this visual

You added build permissions to your shared dataset. Did you add build permissions to the dataset your dataset is sourced from? This typically explains this behavior for us, we build a Report B from Dataset A we must grant permissions at both sources.

could not load data for the visual

Refer to this post here. Your problem might be related. As suggested by the user trying changing data type of column in data source. If you think it is not related then perhaps open a support ticket with MS support.

 

Thanks,
Pratyasha Samal
Has this post solved your problem? Please Accept as Solution so that others can find it quickly and to let the community know your problem has been solved.
If you found this post helpful, please give Kudos C





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!





Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors