Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
tracyhopaulson
Resolver I
Resolver I

Unable to read data from the transport connection

Hello,

I am able to refresh and publish my PowerBi report.  However, the scheduled refresh failed with the error below.  I already adjusted the parallel loading settings to "One" to avoid loading multiple queries at once, but it does not resolve the issue.  

 

"[ValidateMarkupTags][ccon]DataSource.Error: [ccon]Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.[/ccon]. [/ccon];[ccon]Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.[/ccon]. The exception was raised by the IDataReader interface. Please review the error message and provider documentation for further information and corrective action. Table: AppStateTable."

 

Note: The AppStateTable is a query built in PowerBI Desktop using a datasource csv file from SharePoint.  

 

Does anyone know how to fix this issue?  Please help!!! 

1 REPLY 1
v-xiandat-msft
Community Support
Community Support

Hi @tracyhopaulson ,

Please refer to the following topic to see if it helps you.

Solved: "Unable to write to the transport connection." - Microsoft Power BI Community

The report is quite large 162,106kb could this be an issue?

Yes, too large data model may be a reason for your scenario, maybe you can try to cut down you data size and try again.

 

Then I also found a similar blog , please refer to it.

How to Fix 'An Existing Connection was Forcibly Closed by the Remote Host' Error? - Appuals.com

  • TLS 1.1/1.0 Usage: If the application is running on TLS 1.1 or TLS 1.0, it might trigger this error due to them being depreciated. TLS 1.2 is the way to go when selecting the protocol which the application uses.
  • Cryptography Disabled: If Cryptography has been disabled for your machine it will prevent the usage of TLS 1.2 and will fall back on TLS 1.0 which might trigger the error.
  • Socket Implementation: In some cases, a particular type of socket implementation triggers the error. There is a bug with some implementations by “.NET” application and it might cause this error.
  • Missing Code: For some people who were using the Entity Framework, it was observed that a certain line of code was missing due to which the error was being triggered.
  • Outdated “.NET” Framework: In certain cases, if the “.NET” Framework has been disabled, this error might be triggered. Certain tasks require the “.NET” framework to be updated to the latest version in order for them to work properly.

If still not helpful,   I suggest you to open a support ticket for help.

Best Regards,

Xianda Tang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.