Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
mjbernier
Helper II
Helper II

Unable to publish new report to Report Server

We are using the latest Report Server version (January 2021). I am trying to publish a brand new report to our report server and am getting a generic-looking message "An error occurred while attempting to save the report to Power BI Report Server". The data looks good, no errors found. When I check the RSPortal log on the report server I get the following:

 

2021-04-22 12:38:34.3803|INFO|82|Received request GET /api/v2.0/catalogitems(be00ecbf-4e15-4993-b440-82d26c945dd3)/Model.Folder/catalogitems/| RequestID = s_5c4da73e-cfef-4b77-ba27-45565d18336e 
2021-04-22 12:38:34.4193|INFO|27|Sending response. Response code CHOCTAWNATION\mbernier 200, Elapsed time 0:00:00.039015| RequestID = s_5c4da73e-cfef-4b77-ba27-45565d18336e
2021-04-22 12:38:36.1386|INFO|82|Received request GET /api/v2.0/CatalogItems(Path='/Sample%20Reports')| RequestID = s_c62d3031-5274-4d23-8be3-16157fe721db
2021-04-22 12:38:36.1436|INFO|82|Sending response. Response code CHOCTAWNATION\mbernier 200, Elapsed time 0:00:00.0045102| RequestID = s_c62d3031-5274-4d23-8be3-16157fe721db
2021-04-22 12:38:36.1676|INFO|82|Received request GET /api/v2.0/catalogitems(5ace9562-4b52-47d7-8c81-eb253d7449b1)/Model.Folder/catalogitems/| RequestID = s_5f34694a-d610-4b3a-838c-68ece267c134
2021-04-22 12:38:36.1766|INFO|82|Sending response. Response code CHOCTAWNATION\mbernier 200, Elapsed time 0:00:00.0087902| RequestID = s_5f34694a-d610-4b3a-838c-68ece267c134
2021-04-22 12:38:44.5026|INFO|82|Received request GET /api/v2.0/CatalogItems(Path='/Sample%20Reports/EnvironmentalCompliancev1x')| RequestID = s_19e22329-26f4-4dfe-8531-3ffcfa0c2130
2021-04-22 12:38:44.5026|ERROR|82|library|Throwing Microsoft.ReportingServices.Diagnostics.Utilities.ItemNotFoundException: , Microsoft.ReportingServices.Diagnostics.Utilities.ItemNotFoundException: The item '/Sample Reports/EnvironmentalCompliancev1x' cannot be found.;| RequestID = s_19e22329-26f4-4dfe-8531-3ffcfa0c2130
2021-04-22 12:38:44.5026|INFO|82|Sending response. Response code CHOCTAWNATION\mbernier 404, Elapsed time 0:00:00.0027868| RequestID = s_19e22329-26f4-4dfe-8531-3ffcfa0c2130
2021-04-22 12:38:47.0300|INFO|89|Received request GET /api/v2.0/System/Properties| RequestID = s_28fb194a-c67e-4d38-a9f9-f790992097ab
2021-04-22 12:38:47.0350|INFO|89|Sending response. Response code CHOCTAWNATION\mbernier 200, Elapsed time 0:00:00.0045896| RequestID = s_28fb194a-c67e-4d38-a9f9-f790992097ab
2021-04-22 12:38:47.4460|INFO|89|Received request GET /api/v2.0/me| RequestID = s_6d9a1442-0e0c-4894-80aa-dc4b950f365f
2021-04-22 12:38:47.4840|INFO|89|Sending response. Response code CHOCTAWNATION\mbernier 200, Elapsed time 0:00:00.0381886| RequestID = s_6d9a1442-0e0c-4894-80aa-dc4b950f365f
2021-04-22 12:38:47.5190|INFO|89|Received request POST /api/v2.0/powerbireports(Path='/Sample%20Reports/EnvironmentalCompliancev1x')/Model.Upload| RequestID = s_7e3d982f-1cca-492d-826b-39d3357c4cc2
2021-04-22 12:38:47.5190|ERROR|89|library|Throwing Microsoft.ReportingServices.Diagnostics.Utilities.ItemNotFoundException: , Microsoft.ReportingServices.Diagnostics.Utilities.ItemNotFoundException: The item '/Sample Reports/EnvironmentalCompliancev1x' cannot be found.;| RequestID = s_7e3d982f-1cca-492d-826b-39d3357c4cc2
2021-04-22 12:38:48.9512|ERROR|27|The remote server returned an error: (400) Bad Request.| RequestID = s_7e3d982f-1cca-492d-826b-39d3357c4cc2
2021-04-22 12:38:48.9552|INFO|38|Sending response. Response code CHOCTAWNATION\mbernier 422, Elapsed time 0:00:01.4358758| RequestID = s_7e3d982f-1cca-492d-826b-39d3357c4cc2

If I'm reading this right, it says the report server is first checking the folder path to see if the report already exists (several GET commands), then attempts to save the reports to the server (the POST command), but then an error is generated because it can't find the report already in the target folder. I tried this with an existing report and it works just fine.

 

Does this mean that the report server is expecting the report to already exist in the folder before it's added to the folder? Seems like a chicken-or-the-egg scenario. I also tried to manually upload the report through the web interface and get a similar error.

 

How can I fix this?

1 ACCEPTED SOLUTION
mjbernier
Helper II
Helper II

I found the source of the problem. The data source I'm using is a SharePoint Online List, and it's not supported on Power BI Report Server. It works on the cloud service and Desktop... but we can't use the cloud service due to the sensitivity of the data and the need for everyone to have a Pro license to view them. Very short-sighted of Microsoft to do that. I guess I'll have to tell my client we'll have to go another route to generate his reports.

View solution in original post

1 REPLY 1
mjbernier
Helper II
Helper II

I found the source of the problem. The data source I'm using is a SharePoint Online List, and it's not supported on Power BI Report Server. It works on the cloud service and Desktop... but we can't use the cloud service due to the sensitivity of the data and the need for everyone to have a Pro license to view them. Very short-sighted of Microsoft to do that. I guess I'll have to tell my client we'll have to go another route to generate his reports.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors