Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

New Member

Unable to load the model for published report

I have a published PowerBI report that has worked well for months. The data sources are online OneDrive Excel files and our company SalesForce website. Today I just recieved the error message that the report was 'Unable to load the model. Please try again later or contact support..'. I am very perplexed. The report refreshes fine in desktop mode and I have tried re-publishing it and it goes well. But when I go to open the rerpot on line I recieve that error message. I just upgraded to the newest version (June 2018) of PowerBI this morning, maybe it is a compatiabality issue? I need a resolution ASAP

Advocate III
Advocate III

Same thing keeps happening to me as well.  My report is sveral months old, and just since the June 2018 update have I seen issues.  My data moel is built from both SQL Server and Excel files.  When I run in Power BI Desktop it works just fine, but once I publish it I keep getting the "Something went wrong" Unable to load data model error, and lots of little spinning gifs on the report in the Power BI Portal as it is attempting to load.


I am going to try the delete and upload method mentioned, but I would like to hear if there is a better fix.

deleteing both the report and the dataset, and then uploading again seems to have done the trick...for now anyway

Some more explanation :

Sometimes you need to hide/unhide a file.

For us, it's the transition from hide to unhide or from unhide to hide that breaks the data source link.

To change visibilty, use following steps :


1/ Hide or Unhide

2/ Reupload from the file managementhelp for PBI.png3/ You're fine






Regular Visitor


We have the same issue

We upgraded from november 2017 version of PBI Report Server to March 2018 yesterday

And since we've been able to upload a file ! Yeah !

But the file got the worst ! Can't load model ! And it is the same for all users.


Any idea on how to solve it ?


Tip : yes we tried to modify it twice on desktop then reupload, no change.

I've found something :


Try not just to reupload the same file

Try to 1 / delete the file not working then 2/ reupload it


For me, data source section was unmanageble before this manipulation

After that, I can modify the data source connection and I have the whole file working

Frequent Visitor

I am having the same issue, it happens to some users only and in my case the data source is an SSAS multidimensional on premises.

Can you please check ASAP?



HI @ismaelumpierrez ,


I'm having the same issue right now, do you have a solution for this problem?

I can't open the file on desktop and I can't open my published report...

Helpful resources

Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City


Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.