Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
PrahaPalalace
Frequent Visitor

Single Select Slicer not working once published to Report Server May 2019

I was hoping to use the new “single select” slicer in report server introduced in May 2019 version.

 

Unfortunately it is not working for me.

All looks good in Desktop – radio buttons instead of check boxes

 

However when the same report is published to report server it reverts back to multi select, with the ability to clear all filters as before ☹

 

Darren

1 ACCEPTED SOLUTION
PrahaPalalace
Frequent Visitor

FYI - After clearing the browser cache it now works as expected

View solution in original post

8 REPLIES 8
Friedrich90
Frequent Visitor

Hello, for me to reset the filters on Power BI Workspace to standard helped in this case.
Issue reset Slicer.PNG

 

MarijaMil
New Member

Hello guys,

 

I'm still facing this issue. Once the report is published slicer is not radio buton (single select) and should not display Select all. However, on the online version in any of the browsers for some of users it shows checklist (multi-select works) and also Select all option.

 

Clear browser does not work. The issue still exists on the multiple browsers.

 

Thank you for your help in advance!

ua_
Frequent Visitor

Hi,

I am experience the same issue, is there a solution that works to solve it?

conorl
Advocate I
Advocate I

I too was experiencing this issue. Post publishing, my once single-select slicer had now become a multi-select slicer.

I fixed this by editting the slicer's settings while editing the published report in the online service instead of the app.

yerdaman
Advocate I
Advocate I

I experienced same problem. Clearing the browser cache did not fix it nor did alternate browser.

 

Issue was remedied by

(1) Create a brand new slicer on model.

(2) Copy formats from original (problematic) slicer then paint on new slicer

(3) Delete original slicer and republish.

 

Worked for me 

PrahaPalalace
Frequent Visitor

FYI - After clearing the browser cache it now works as expected

Hi,

 

I am facing the same issue. I have a single selection slicer that works fine locally.

However, when I publish my PowerBi report, it changes to multi-select.

I have cleared my browser cache, tried several other browsers, but nothing seems to work.

Did you ever find a solution to this?  Slicers remaining multi-select after publishing, when they're single-select locally in Desktop?

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors