Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
lo_p_ez
Helper I
Helper I

SSAS live connection grayed out

Hi,

 

I'm testing the Power BI Report Server. I could install it and can access through the url.

 

My understanding is that for the report to upload correctly it needs to have SSAS live connection only. However, on Power BI Desktop (Report Server version) when I try to access this option is grayed out... Anyone can give me some insights to why this is happening?

 

ssas live.PNG

 

I tried to upload a file with a PowerQuery-generated table as in Chris Webb's blog but it returns me the following error:

 

"We can publish this Power BI Desktop report because it contains an unsupported data source connection or embedded data. This preview version supports only Power BI Desktop reports that connect live to SQL Server Analysis Services (on-premises)".

1 ACCEPTED SOLUTION
mgmeyer
Power BI Team
Power BI Team

Looking at what you have in the dialog it could be one of two things:

 

  1. The name of the server has to be the server name for the Analysis Server machine, you have myreportserver. Do you have Analysis Services installed on that machine?
  2. If you do have Analysis Services installed on that machine then you may have AS installed under a different instance name. If that is the case you will need to include the instance name in the server name (ServerName\InstanceName)?

Once you have a valid AS Server name and instance in the box the option should no longer be grayed out.

View solution in original post

2 REPLIES 2
thebeautiful
New Member

you can only have live connection when there are no other data sources with imported data.

mgmeyer
Power BI Team
Power BI Team

Looking at what you have in the dialog it could be one of two things:

 

  1. The name of the server has to be the server name for the Analysis Server machine, you have myreportserver. Do you have Analysis Services installed on that machine?
  2. If you do have Analysis Services installed on that machine then you may have AS installed under a different instance name. If that is the case you will need to include the instance name in the server name (ServerName\InstanceName)?

Once you have a valid AS Server name and instance in the box the option should no longer be grayed out.

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors