Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
dsmudge35
Frequent Visitor

RSConfigTool.exe not finding Report Server Instance

Hi, 

I have a Development PowerBI Report Server setup with - Version: 1.9.7675.15620 (Build 15.0.1104.300), Released: January 8, 2021  

thats been in operation for over a year and planning to upgrade to latest version. However when trying to use the RSConfigTool.exe (Report Server Configuration manager) from the actual report server or another report server, it does not find the Report Server instance and there is no error to assist troubleshooting.   All other PBI RS setups we have connect fine.

 

I'm comparing this Dev Setup with the other working environments i.e QA, UAT and PROD and cannot find any differences.

 

Any other ideas what the problem could be here and how to resolve this? 

 

Thanks

Darren

1 ACCEPTED SOLUTION

I'd suggest trying to re-run the installer and choose the "repair" option. That should hope fully fix issues like this.

View solution in original post

4 REPLIES 4
dsmudge35
Frequent Visitor

Yes its only the Development environment which is running the Development edition, the other 3 environments are using Enterprise edition.   Additionally I have downloaded the SQL Server Reporting Services PowerShell utilities and tried to connect to the server via Powershell and have issues, it appears that a namespace value is missing i.e

 

No Value is returned when executing this on the Development server:

Get-WmiObject -Namespace "Root\Microsoft\sqlserver\ReportServer" -Class __Namespace | Select-Object -Property Name | Sort Name

 

Executing on the other 3 setups returns a value of -   RS_PBIRS

 

Unsure how to fix this. 

 

 

I'd suggest trying to re-run the installer and choose the "repair" option. That should hope fully fix issues like this.

Thanks d_gosbell for your suggestion, I did actually do this prior to your message & it resolved the issue and then allowed me to upgrade succesfully so all sorted thks

Icey
Community Support
Community Support

Hi @dsmudge35 ,

 


 

However when trying to use the RSConfigTool.exe (Report Server Configuration manager) from the actual report server or another report server, it does not find the Report Server instance and there is no error to assist troubleshooting.   All other PBI RS setups we have connect fine.

 


Only the development mode of this verison (Version: 1.9.7675.15620 (Build 15.0.1104.300), Released: January 8, 2021) has the issue?

 

The others which work are other versions? Are all related sql server services running?

 

In addition, please check if there is any useful log here:

C:\Program Files\Microsoft Power BI Report Server\PBIRS\LogFiles.

 

For your data security, please don't paste your log here.

 

 

Best Regards,

Icey

Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.