Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
PBI_RS_User
Frequent Visitor

PBI RS (May 2021) report URLs changing or changed & Email subscription links (paginated reports)

I had a user point out that the url link that PBI RS inserts at the bottom of an email body does not take them to the report, but rather a variation of the reports' url resulting in a "Not Found HTTP Error 404. The requested resource is not found." error.

 

In looking at the issue closer I found that after upgrading report server to May 2021 version that report urls are changing when the report is accessed.

PBI RS Folder URL - 2021-09-29_10-54-10.png

 

Once the report is accessed by a user, the reports' url is getting "/report/" added to the url.  This is where the "Include Link" function for paginated report subscriptions breaks for users.

PBI RS Report URL - 2021-09-29_10-54-10.png

This is new behavior to me, I need to resolve it.  Please help.

1 ACCEPTED SOLUTION

The issue was with the values in the <UrlRoot> & <ReportServerUrl> tags not being set to the virtual directory/web service url in the rsreportserver.config file.  They were only set to the server's FQDN.

View solution in original post

11 REPLIES 11
Petebro
Microsoft Employee
Microsoft Employee
Petebro
Microsoft Employee
Microsoft Employee

Hmm interesting...

 

A report located at:

http://foo/reports/report/AdventureWorks-Company%20Sales

 

should generate a url:

http://foo/ReportServer/Pages/ReportViewer.aspx?%2fAdventureWorks-Company+Sales

 

I think you might need to contact support as I don't want you to have to expose your company information here publically. I would say double check that the ServerName.FQDN replaced above contains http(s)://(server)/(reportserver)/ format.

That is what I was thinking too (contact support).  Can you help me with the appropriate place to start the process to contact support?  I have been looking around but am seeing avenues that take me to a forum, not a "contact us" type of form for official support.  Thanks in advance for all of your help thus far.

Hi @PBI_RS_User ,

 

Have you created a support ticket? Could you share us the solution if the issue is solved?

 

 

Best Regards,

Icey

The issue was with the values in the <UrlRoot> & <ReportServerUrl> tags not being set to the virtual directory/web service url in the rsreportserver.config file.  They were only set to the server's FQDN.

Petebro
Microsoft Employee
Microsoft Employee

The pattern <reports uri>/report/<Path to report> is the expected path for any given RDL report on a Report Server instance and has not changed in some time. Be default the url at the bottom of the subscription goes to the /reportserver/ endpoint not /reports/  the reportserver endpoint does not have the /reportserver/report instead just has /reportserver/<path> this might be what is leading you to assume this is the issue. 

 

However, back the original concern. Can you trigger a subscription now for the report in question to just yourself and verify if you are getting the 404 still? It could have been a rename or move of the report after the subscription fired and a one time failure. 

Thank you for the explanation.  I have triggered, and retriggered existing and new email subscriptions and can continue to get the 404 error.  I have tested both existing and newly created reports and subscriptions, it is reproduceable on-demand.  Here's another screenshot of the url that comes via email and what the url is when navigating via browser in PBI RS.

Email Subscription URL Differences - 2021-09-30_8-41-05.png

 

And where the url takes the users:

Email Subscription URL Destination - 2021-09-30_8-41-05.png

ponnusamy
Solution Supplier
Solution Supplier

@PBI_RS_User :  While upgrading to May 2021,  the default URL might have got modified.

 

You can change the web portal URL ( the report URL) by going to Report server confiuration manager -> Web Portal URL -> Virtual Directory

 

ponnusamy_0-1632946392649.png

 

If this post helps, then please consider Accepting it as the solution, Give Kudos to motivate the contributors.

I definitely checked this setting, it is the same as it was (/Reports).  The url still adds another "/report/" after the web portal url (the screenshots showcase this).

@PBI_RS_User : Do you have scale-out deployment? , if so, check other servers too.

 

ponnusamy_0-1632953175427.png

 

If this post helps, then please consider Accepting it as the solution, Give Kudos to motivate the contributors.

 

I am using scale-out deployment, I am getting the same behavior from all of my instances (all on May 2021 PBI RS) regardless of whether they have any other servers joined in that way.

PBI RS Configuration Virtual Folder - 2021-09-30_7-54-17.png

It looks like if it's a PBI dashboard, "/powerbi/" is added after the web portal url.

PBI RS Dashboard URL - 2021-09-30.png

And if a report builder file is accessed, "/report/"  is added after the web portal url.

PBI RS Report Builder URL - 2021-09-30.png

 

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.