Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

New Member

Excel Online not working in PBIRS

We downloaded and installed the PBIRS preview for August.  Pbix files work as do RDL reports.  I can upload Excel files as well. We also installed OOS on the test PBIRS server and configured using http. The issue I have is when i click to open the Excel file, I receive an error: "Unable to Open the file. We couldn't find the file you wanted. It's possible the file was renamed,moved or deleted."  The file was not any of these suggestions.  It is where I specified on upload.  I have searched for this issues but i get info related to SharePoint, which this is not.  What am I missing?  Thanks!

New Member

We had this same issue and we solved it by logging into the Power BI Report Server using the fully qualified domain name. 


In our example, our initial state was:


- Power BI Report Server installed on the same server as SQL Server 2012 Enterprise on domain ExampleDomainB. 

- The Report Server address used was - http://<sqlserverWithPowerBI>/Reports/Browse

- Office Online Server installed on a different server and NOT using the fully qualified domain name and on a different domain (ExampleDomainA) - http://<oosServer>/hosting/discovery


The revised state which solved the issue:


- Power BI Report Server installed on the same server as SQL Server 2012 Enterprise on domain ExampleDomainB. 

- The Report Server address used was - http://<sqlserverWithPowerBI>.ExampleDomainB.local/Reports/Browse - Made Address fully qualified.

- Office Online Server installed on a different server and using fully qualified domain address - http://<oosServer>



Frequent Visitor

Similar issue here.


Excel files can be rendered properly in Excel Online (SP 2016 + Office Online On Prem), but not from PBIRS August 2017 Preview.


Received an error regarding the address , to check if it is correct. 


The settings is Ok and the address is good and it's working properly. 


At the end, can't render Excel file from PBIRS.


Any help or suggestions would be appreciated,






Are both OOS and PBI Report Server on the same machine?  If so, try restarting the Power BI Report Server service on the machine and see if that addresses the issue.  Don't restart the entire server, just the service itself.  That should clear up the issue.  

Yes, both PBIRS and OOS are on the same server.  I tried restarting the services first thing as well and the error still comes up.

Something to check is the following folder location - C:\ProgramData\Microsoft\OfficeWebApps\Data\FarmState\Topology.xml


It'll show you the current machine state.  If it says "Unknown", then the machine has somehow gotten into an unrecoverable state for Office Online Server and you'll need to start fresh on a new VM.  There are some articles on the web stating you should be able to fix the XML and have it start working again, but we've not seen that actually work in our case.  This happens very infrequently, but we've had it occur once or twice and haven't found a way to recover from this state.  It doesn't have anything to do with Report Server from what we can tell, but rather some combination of items/settings on the machine.  We've asked for additional details from the Office server team to understand what that may be. 


If it says "Healthy" or "Unhealthy", then it should still be in a state where it can be recovered and usually restarting the service will do that.  You might want to look at the ULS logs in OOS to see if anything jumps out there as well (the logs are in the Data folder in the path I gave you above).  Beyond that, you could look to set things up on two different machines (OOS on one, PBI RS on another) and see if you still have the issue.    


FWIW, when the features in August preview go live in the next update, we have improved this setup experience so you shouldn't ever need to restart the service after initial setup just to get things working in certain cases.





The Topology.xml file states that everthing is "healthy".  There isn't much else in that file, should there be?  Also, i did not see anything that stood out in th ULS logs so i am at a loss, other than setting up two different machines for this configuration. 

Hmm - one last thing, are you using the "internal" or "external" url you setup for OOS as the URL?  You could try switching the URL you're using from one to the other (though it shouldn't make a difference).  Failing that, I'd ask you contact Microsoft support so they can dig into it more thoroughly with you. 

That was the only thing i had left to try. I am using the internal URL. I need to configure it for the External.  Thanks for the help!.

I reconfigured the OOS to use the FQDN. Set up worked without issues.  Still get the same error when clicking on the Excel file to open.  I debugged the session and found these errors:


SCRIPT7002: XMLHttpRequest: Network Error 0x80070005, Access is denied.

http://<SERVERNAME>/reports/assets/css/ HTTP GET 404  0 B 233.82 ms XMLHttpRequest


So the 404 is cause by the access denied? Why do i not have access to my Excel files? 

Can you also check the PBIRS logs for any errors? The Excel logs filenames start with RSOffice.


I see these errors:

2017-09-29 13:24:23.1397|INFO|22|Received request GET /files/14f30070-60f9-4698-b2c1-359d23641862| RequestID = s_312f39ba-c04c-47fb-b3d2-2772deb31d74
2017-09-29 13:24:23.1397|INFO|22|CFG : OfficeOnlineDiscoveryUrl = [] (env)
2017-09-29 13:24:23.1397|INFO|22|CFG : OfficeAccessTokenExpirationSeconds = [300] (env)
2017-09-29 13:24:23.1397|ERROR|22|Office online discovery url is null or empty.| RequestID = s_312f39ba-c04c-47fb-b3d2-2772deb31d74
2017-09-29 13:24:23.1397|ERROR|22|Failed to load office proof keys from | RequestID = s_312f39ba-c04c-47fb-b3d2-2772deb31d74


The 1st error makes no sense as the discovery URL was valid and accepted in the site settings when i applied the change.  And the xml displayed when i used the URL in a browser. i do not understand why OfficeOnlineDiscoveryUrl is null.

I am not sure why this is happening. Can you please open a ticket with Microsoft support?

Yes we will. I asked the guy in charge to open the ticket.



Not applicable

By any chance were you able to get a resolution for Office Online Server not working to open the files?  Our initial install and configuration of PBI Report Server and OOS worked just fine. Once we switched to using SSL and https then we ran into this issue where we couldn't load Excel workbooks in the browser anymore.  Just curious if you were able to get a resolution or if might need to wait for the non-preview version of this.  Thanks.

Yes. It was related to a certificate configuration on the Server.


The error message we were having was misleading.  The error message we got: "The page cannot be displayed  Check the Web address https://ab-cdef12.ghi.klmn is correct", should have referred to a different message regarding the certificate instead.


To fix it quickly , in order to trust the certificate we imported the certificate into the browser and used the same discovery end point with Https - . At this time we were able to open the Excel file with the PowerBI report server


We asked our IT guys if they can use the trusted certificate from well-known CA and also ensure the certificate is in root trusted folder(Trusted People certificate store on the server).






Not applicable



So not the same issue then.


I believe I might have just resolved our issue. I believe I change the PBI RS service account at some point from the Virtual Account to a domain account.  I just added this domain account into the Administrators group on the server and it has fixed our issue. Now the Excel workbooks load in the browser.


Thanks for the quick reply, greatly appreciated.

The 404 is normal, the .map files are used for debugging, the Chrome DevTools (and the equivalent for other browsers) ask for those files, the regular user won't hit this error.


The access denied might be because of the IFRAME URL issue, but it's hard to know without debugging.

On my side the machine state is Healthy. And I still receive the following error in PBIRS:


"The page cannot be displayed

Check the Web address https://ab-cdef12.ghi.klmn is correct"


This address correspond to the prefix of the url for the Office Online Server Discovery Endpoint URL, but truncated by 1 character.


The full url in PBIRS is:




I'm not sure why in the error message, the url prefix is truncated by 1 characters.


Is there a limitation on the length for the discovery endpoint URL ?


If I check the URL, https://ab-cdef12.ghi.klmnO/hosting/discovery  it is working properly.


And on SharePoint , Excel files can be rendered properly in the browser.


Any help would be appreciated,










Can you check (in the browser) the IFRAME URL? Search for a form with ID "office_form" in the HTML source code, and it should have an action attribute of format https://ab-cdef12.ghi.klmnO/x/_layouts/xlviewerinternal.aspx?WOPIsrc=...

Also, in the discovery document, what is the corresponding URL? Search for an action element of format 

<action name="view" ext="xlsx" default="true" urlsrc="https://ab-cdef12.ghi.klmnO/x/_layouts/xlviewerinternal.aspx?<ui=UI_LLCC&><rs=DC_LLCC&><dchat=DISABLE_CHAT&><IsLicensedUser=BUSINESS_USER&>"/>

In both cases, see if the URL hosts are truncated or not.

Also, is the last character in the host URL (the O in your example) a special character?

Helpful resources


Fabric certifications survey

Certification feedback opportunity for the community.


Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Kudoed Authors