Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Gandhar09
Regular Visitor

Error while connecting PostGres to Power BI

I'm trying to connect my Power BI Desktop to Post Gres SQL. 
I get the following error when I tried to connect. 

Details: "Loading assembly file 'System.Runtime.CompilerServices.Unsafe, Version=4.0.4.1, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' failed for data source type 'PostgreSQL'"

Gandhar09_0-1720556049252.png

 

With the same credentials, im able to connect to the MY SQL workbench

1 ACCEPTED SOLUTION
v-jianpeng-msft
Community Support
Community Support

Hi, @Gandhar09 

First, you can check if the current version and the NET Framework are compatible. To use this connector, you can check if you fulfill the current requirements:

Power Query PostgreSQL connector - Power Query | Microsoft Learn

vjianpengmsft_0-1720575909047.png

In the case below there is feedback from other community members that there is an incompatibility when connecting at version 4 and above:

Error connecting to PostGresSQL db - Page 2 - Microsoft Fabric Community

vjianpengmsft_1-1720576225885.png

You can also check the case below:

Postgre SQL x Power BI - System.Runtime.CompilerSe... - Microsoft Fabric Community

Solved: Unable to start Power BI Desktop. Could not load f... - Microsoft Fabric Community

Solved: Latest Update Creates Login Error - Page 2 - Microsoft Fabric Community

vjianpengmsft_2-1720576388690.png

 

 

Best Regards

Jianpeng Li

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

 

View solution in original post

1 REPLY 1
v-jianpeng-msft
Community Support
Community Support

Hi, @Gandhar09 

First, you can check if the current version and the NET Framework are compatible. To use this connector, you can check if you fulfill the current requirements:

Power Query PostgreSQL connector - Power Query | Microsoft Learn

vjianpengmsft_0-1720575909047.png

In the case below there is feedback from other community members that there is an incompatibility when connecting at version 4 and above:

Error connecting to PostGresSQL db - Page 2 - Microsoft Fabric Community

vjianpengmsft_1-1720576225885.png

You can also check the case below:

Postgre SQL x Power BI - System.Runtime.CompilerSe... - Microsoft Fabric Community

Solved: Unable to start Power BI Desktop. Could not load f... - Microsoft Fabric Community

Solved: Latest Update Creates Login Error - Page 2 - Microsoft Fabric Community

vjianpengmsft_2-1720576388690.png

 

 

Best Regards

Jianpeng Li

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

 

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors