Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
PeteDTG
Frequent Visitor

Data Source Refreshing Fine - data disappears from visuals

Hello,

 

I'm having an issue with a few reports lately.  The reports refresh with no error on a schedule, but after the refresh the data completely disappears from any of the visualizations contained within the report. 

 

This does not happen everytime, but enough to where it has become an annoyance.  I cannot figure out why this is occurring and have tested everything possible that I am aware of.   If I download the report to desktop it refreshes fine and returns the data.  If I manually run the refresh in service it again seems to refresh fine.  

 

These reports do not need a gateway because all of the data sources are in Azure.  I'm also not using any boolean logic in any of the DAX formulas and I am using a dimensional date table that has been marked as the date table.  Dates are all correctly formatted.  I've also deleted the reports and republished and the same issue still occurs.

 

Any ideas?  I've opened up a support ticket as well. 

 

Thanks,

Pete 

 

1 ACCEPTED SOLUTION

After many attempts, with nothing working at all (changing data formats, boolean logic, etc.), I set the Power BI datasets to refresh in Azure after my pipelines had successfully completed.  I run my pipelines every 30 minutes and refresh my Power BI datasets every 30 minutes as well. 

 

I believe my pipelines were not completing fully, before the Power BI dataset refresh, causing only partial data to be imported.  

View solution in original post

8 REPLIES 8
v-luwang-msft
Community Support
Community Support

Hi @PeteDTG ,

Has your problem been solved, if so, please consider Accept a correct reply as the solution or share your own solution to help others find it.

Best Regards
Lucien

After many attempts, with nothing working at all (changing data formats, boolean logic, etc.), I set the Power BI datasets to refresh in Azure after my pipelines had successfully completed.  I run my pipelines every 30 minutes and refresh my Power BI datasets every 30 minutes as well. 

 

I believe my pipelines were not completing fully, before the Power BI dataset refresh, causing only partial data to be imported.  

v-luwang-msft
Community Support
Community Support

Hi @PeteDTG ,

If you with  date/time format in you report?if so ,try to changed your date/time format to date only format in the query editor.refer link

Here are some similar post for you refer to:

https://community.powerbi.com/t5/Service/Power-BI-Service-Data-Missing-after-refresh/td-p/495798

https://community.powerbi.com/t5/Service/Power-BI-Report-not-showing-data-after-publishing-to-Servic...

https://community.powerbi.com/t5/Issues/Visualization-BLANK-after-refreshing-page-in-Power-BI-servic...

 

Did I answer your question? Mark my post as a solution!


Best Regards

Lucien

PeteDTG
Frequent Visitor

@Anonymous  

 

I tried changing the name of the report and re-scheduling it.  I had the same thing happen twice yesterday.  Report refreshes successfully but the visuals go blank (no data).  Any other suggestions?  Thanks!

PeteDTG
Frequent Visitor

Got it.  I've republished the report with a different name and rescheduled it.   I kept the original report out there as well, so that I can monitor both. 

 

Thank you kindly for the suggestion.  

Anonymous
Not applicable

Hi @PeteDTG 

 

I think this has something to do with cache.

I would suggest deleting the scheduled refresh and the report.

Resave the report but with a different name and a new scheduled refresh with a different name.

See how you go with that.

Happy to help 🙂

@Anonymous thanks for the response I do appreciate it.  

 

I have tried deleting the report and dataset from service and republishing already.  Although I never tried changing the name of the report.  I will try deleteing, renaming the report, and schedule the refresh again.  I'll let you know if that has any impact. 

 

Thanks,

Anonymous
Not applicable

Good luck. I have had the same problem and deleting and republishing does not work as I think it had something to do with the cache and I don't know how to clear it.

Changing to a new name eg Dashboard Q4 --> Dashboard - Q4

tricks it to thinking it is a different report. Even though it does schedult to refresh, it kind of caches the data.

Good luck

Helpful resources

Announcements
Fabcon_Europe_Social_Bogo

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.