Showing results for 
Search instead for 
Did you mean: 
Helper I
Helper I

An unexpected error occurred - We couldn't connect to the Analysis Services server.


One of our users is experiencing issues with a particular report that uses Direct Query. The report runs fine on desktop but "breaks" when published to our on-premise report server. They receive the error listed at the bottom of this post.


We've tried workarounds suggested in other posts (to re-enter the credentials, use a particular browser, etc) but are unable to get this report to work. Any ideas?

We are running the January 2020 version and the report is hitting an Oracle 12cR1 DB.


An unexpected error occurred
An unexpected error occurred. Please try again later.
Please try again later or contact support. If you contact support, please provide these details.


We couldn't connect to the Analysis Services server. Make sure you've entered the connection string correctly.
Request ID9edad44b-35bc-7be3-8fc7-bf08910ef59b
TimeThu May 14 2020 13:53:58 GMT-0400 (Eastern Daylight Time)
Service version/powerbi/libs



In case anyone else was struggling with this, we installed the May 2020 PowerBI RS release and it resolved our Oracle related Direct Query issues.

View solution in original post

Regular Visitor

I had the same issue today (11/13/2020). I had to check all my query steps to find the values missing after the refresh. I found that in one of the queries, the Power query changed the column type from text to numbers (customer ID number), which caused the unexpected error in Power BI. After I changed back the values from number to text (before the merge step), the error gone. I found during the refresh some values change automatically. 

Super User
Super User

The first two things I would check if the model works in desktop but not on the server are:


1. Do you have the same Oracle drivers installed on the server as on the client PC

2. Make sure they are using the actual server name when creating the connection in desktop not a TNS name


I'm not entirely sure if 2 is an issue with the Power BI provider, as we don't use Oracle at all where I am at the moment. But I've seen this before where users build things using a reference defined on their local machine which then breaks when anyone else tries to use it.

Yeah the ODAC versions are different. We are running 18c on the server and the customer was running 11g.

We also tried using the host:port/service name but it threw TNS error instead.

It looks like direct query is not working at all on our report server. I will try different ODAC versions on our test environment until we figure this out.

Thanks for the tips.

In case anyone else was struggling with this, we installed the May 2020 PowerBI RS release and it resolved our Oracle related Direct Query issues.

Helpful resources

PBI Sept Update Carousel

Power BI September 2023 Update

Take a look at the September 2023 Power BI update to learn more.

Learn Live

Learn Live: Event Series

Join Microsoft Reactor and learn from developers.

Dashboard in a day with date

Exclusive opportunity for Women!

Join us for a free, hands-on Microsoft workshop led by women trainers for women where you will learn how to build a Dashboard in a Day!

MPPC 2023 PBI Carousel

Power Platform Conference-Power BI and Fabric Sessions

Join us Oct 1 - 6 in Las Vegas for the Microsoft Power Platform Conference.