Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
bTakcay
Regular Visitor

Reflex does not trigger custom action automatically, but "Send me a test alert" works

Hello 

The data coming from Eventstream to Reflex does not trigger the Custom Action (a Power Automate flow) I created on the Act card.

"New data arrives" is selected on the Detect card, so the custom action needs to be triggered every time new data arrives. When new data arrives it shows under "Trigger Activations" but the triggering does not happen automatically. It does not give any error. Nothing happens.

But when I click on "Send me a test alert" it works correctly. The custom action is triggered and Power Automate flow runs correctly.

Can anyone let me know what's wrong? 

bTakcay_0-1710770790140.png

 

bTakcay_1-1710770790146.png

 

2 REPLIES 2
bTakcay
Regular Visitor

Hi @v-junyant-msft,

 

Firstly, thank you for your comment. So,

1- Yes, i started the trigger by clicking "Start" from the toolbar in Data Activator.

2- I copied and pasted it connection string to "When a Data Activator trigger fires" connector in Power Automate, as it explains here:

https://learn.microsoft.com/en-us/fabric/data-activator/data-activator-trigger-power-automate-flows

3- There is no "recipient" on my action card directly, as i'm using custom action. I just choose the custom action that i want to use.

To test the recipient issue, i created a Power Automate flow with some simple actions like setting a variable only (no such things like sending email or message). So, there is no recipient in the flow as well. However, again, it did not work. It did not trigger the custom action. (But "send me a test alert" works correctly.)

4- Since i can see the new data arriving in "Trigger Activations" graph, i assume there is no problem about data arrivals.

 

Regards

 

v-junyant-msft
Community Support
Community Support

Hi @bTakcay ,

Firstly, it's important to ensure that your trigger is not in a 'Stopped' state. Triggers are created in a 'Stopped' state by default and need to be manually started. You can start your trigger by selecting Start from the toolbar in Data Activator. This action changes its state to 'Running', allowing it to evaluate incoming data and take specified actions. 
Secondly, verify that your custom action is correctly configured to be called by the trigger. This involves ensuring that the connection string is correctly pasted into your Power Automate flow and that the input fields are correctly mapped. Incorrect configuration can prevent the trigger from calling the custom action even if the trigger itself is activated.

In addition this, when you click "send me a test alert", the alert always goes to you, regardless of who the recipient is on on our action card. Can you confirm that the "recipient" section of your action card is you? And specifically is the same user that you're logging into Fabric as?
Also, Trigger will only be triggered if your data exceeds the threshold you set, so please make sure that the new data arrives when you say it does.

Best Regards,
Dino Tao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayFBCUpdateCarousel

Fabric Monthly Update - May 2024

Check out the May 2024 Fabric update to learn about new features.

Top Kudoed Authors