Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
googlogmob
Advocate II
Advocate II

The import Percentage.Type matches no exports. Did you miss a module reference?

Hi

I created MailChimp report in Power BI Desktop

And on PB Desktop it refresh without any errors

But after publishing it on Service I have got the error

"The import Percentage.Type matches no exports. Did you miss a module reference?"

Here is screen

What is the cause of the error?

19 REPLIES 19
ReportMaster
Post Patron
Post Patron

Hi @googlogmob I know this reply is very late. Since there’s no built-in connector for Mailchimp to PBI anymore, you will have to look for another way. As a workaround, maybe you can use a 3rd party connector, it can save you a lot of time compared to the other options. I've tried windsor.ai, supermetrics  and funnel.io. I stayed with windsor because it is much cheaper so just to let you know other options. In case you wonder, to make the connection first search for the Mailchimp connector in the data sources list:

 

MAILCHIMP-1.jpg

 

After that, you will have to first create a secret API key in your Mailchimp account and then using your credentials add your account to the platform.

 

MAILCHIMP-2.jpg

 

Once you’ve done this, you can proceed and go to the “Preview and destination” step

 

MAILCHIMP-3.jpg

 

There just select the fields you need. Finally, just select PBI as your data destination and finally just copy and paste the url on PBI --> Get Data --> Web --> Paste the url. 

 

SELECT_DESTINATION_NEW.png

KEerkes
Regular Visitor

I just got this message today after adding a new page to a report my company has published.

 

This is a huge bug and needs a fix!

Anonymous
Not applicable

Just received this error as well.

 

Quite ridiculous that you cannot publish with a percentage type column.

 

this needs to be fixed asap.

benedict_kmu
Regular Visitor

I am facing the same issue in our production environment and am looking for the resolution or an alternative option to mitigate the issue.

As a workaround you can convert Percentage type columns to Decimal. Then in the model choose to display Decimal as Percentage.

@gabrielius Thanks. Let me give a try. I appreciate your quick turnaround.

RE
Helper I
Helper I

I'm also having an issue with this. Nice to know I'm not alone but the solution continues to elude me. 

Anonymous
Not applicable

I am experiencing this error as well, and your solution did not resolve the problem for me.

 

It is preventing me from performing a scheduled and on-demand refresh of data. 

 

Last refresh failed: Sun Jan 15 2017 13:11:59 GMT-0500 (Eastern Standard Time) 
Hide details
Data source type:	
Processing error: The import Percentage.Type matches no exports. Did you miss a module reference?
Cluster URI:	WABI-US-NORTH-CENTRAL-redirect.analysis.windows.net
Activity ID:	7892ed6d-535a-47df-b7eb-6286e836077f
Request ID:	125e111f-e623-4c40-b019-8d249578e154
Time:	2017-01-15 18:11:59Z
googlogmob
Advocate II
Advocate II

The error has been corrected

I deleted all percentage convertation in PowerQuery

Maybe Power BI service does not work with percentage data type in PowerQuery

Hi @googlogmob,

Glad to hear the issue is resolved,  you can accept your reply as solution, that way, other community members would benefit from your solution.

Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I dont see this as a solution.  You can provide a "Percentage" data type converted column in the PowerBI desktop and yet once you publish, you cannot refresh the data.

 

This is bug that we need to have resolved in the refresh logic.

I am experiencing the same problem.

I created the Issue in PowerBI Ideas, you can vote for it: 

https://ideas.powerbi.com/forums/360879-issues/suggestions/17764717-failing-dataset-refresh-the-impo...

Hi,

I am having the same issue with Power BI service. When I tried voting for the issue on the link - it says voting closed. Do you know what does it mean?

 

Percentage is very essetial for power BI and not having facility on power bi service is such a bummer !

While Microsoft works on the issue, I have found a workaround that allows for Web interface scheduled refresh and manually refresh so you dont have to constantly publish your data set.  

 

If you converted the data to percentage type, remove that "Changed Type" from your applied steps.  you can also find in the advanced editor (right click on your querie and click Advanced Editor) with anything labled as "percentage.type" Example: 

  

  #"Changed Type1" = Table.TransformColumnTypes(#"Renamed Columns2",{{"Current Occupancy", Percentage.Type}, {"16 - 17 Opening Occ", Percentage.Type}}),

 

^^Delete all of those references

 

Once you remove all of those, leave the data as a decimal and create a calculated measure to produce the percentage.  This way, it does not find that Percentage.Type error upon refresh and works just fine.  

 

Not a permanent solution, but a resolution to a crippling refresh issue... 

@gabrielius and @mzikra - The work around is working fine. Thanks for your assistance.

Anonymous
Not applicable

I have a problem being thrown saying it can't find the module import List.Zip(), which is a standard M function. However, in the line after I do use Percentage.Type. So this may be the problem.

 

Either way it is pretty annoying not knowing exactly where bugs are or what is causing it. Maybe MS should remove Percentage.Type until it is fixed.

 

And potentially List.Zip as well.

Anonymous
Not applicable

It's flagged as "Escalated", so that's why voting is closed. 🙂

Anonymous
Not applicable

+1 for bug... hope we get an update with solution fast... seems like a very simple solution to implement on the development side of Microsoft.

I agree that this should be considered a bug.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

Top Solution Authors
Top Kudoed Authors