Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Helper I
Helper I

SAP BW connectivity issue with a port number

Hi all,


I am trying to integrate our SAP BW system with Power BI.

Fo test enviroment evrything is working fine, however when I am trying to make connection is fails.

The difference is that for Production enviroment I need to specify port in a server address like:

whereas in test it is just address like:


With port number I have error: Details: "The provided server name is invalid."

Whereas without port number Bi is directing to the worng port:


Details: "SAP Business Warehouse: RfcOpenConnection failed(RFC_COMMUNICATION_FAILURE):
LOCATION CPIC (TCP/IP) on local host with Unicode
ERROR partner '' not reached


Any idea how I can force Power BI to use proper port?



Frequent Visitor

I am having the same problem so can't get to step one with this tool.  The port to initiate connection to the BW server is controlled by POWERBI.  I don't see how the configuration of the SAP server would have anything to do with it.  I find no way to change it in the tool, registry, or configuration files within POWERBI.

Frequent Visitor

Although I changed nothing on my client, the BW connection began working a couple of days later when I tried again.  Some windows updates had been applied to my machine, but I suspect that the reboot that was performed had something to do with it starting working.  Our BW system must be using the default port used by the data source extract.

Community Support
Community Support

Hi @lewand03,


From the description, the SAP BW service is configured to use specific port. You need to contact the SAP BW administrator to set the default port for


Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thank you @v-qiuyu-msft


Your soulution sound reaspnable, and I'll try to talk to my administrator, however I'd prefer any solution whic doesn't impact other 2500 users, portal settings etc.


Is there any way to force Power Bi to use proper port?




Hi, I have the same problem and context (no way I can have the port number of our Prod BW landscape change to default...): any chance to have a way to specify / force a different port number ?



Did anyone ever find a solution to this issue?  I think its a port isue for me also.  The error references 3300 port but I believe my SAP BW is on 3317.  How do I tell Power BI to use port 3317?



Not applicable

You should write 17 as value of System number parameter of connection to SAP BW.

Helpful resources

Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.


Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors
Top Kudoed Authors