Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
chrisk16
New Member

Refresh Failed - CRM Online oAuth2 - Losing Credentials/Credentials Invalid

We're connecting to various CRM Online environments through ODATA with Organisation/oAuth2 credentials in Desktop/WebApp settings.   In the Web App all datasets are failing to refresh as randomly chosen credentials from the various services are shown as invalid (changes to Anonymous and loses previously stored credentials).  This causes the refresh to fail and the scheduled refresh to deactivate.   Entering all correct credentials, re-scheduling refresh and waiting patiently with the same browser session open has the same result.

6 REPLIES 6
jperry1120
Regular Visitor

I have the same issue.....Has this been resolved?!?

This looks to be now resolved. 

No, still doesn't work for me.  I've tried doing 2 simple test connections and that didn't work either.

jasonscript
New Member

UNfortunately I'm getting the same error.

The Report queries all work (slowly) in Power BI Desktop (pbix files) but once uploaded, the dataset won't refresh successfully. I have to go to settings and update all the OData connections to use OAuth2 and enter my credentials. Then clicking refresh on the report will take a long time and then result in errors such as described by the original poster.

 

When I return to the OData connections in settings, I can see that the authentication has reverted back to anonymous. This is really frustrating

Hi Did anyone find a resolution for this issue?

chrisedwards
Regular Visitor

I can confirm this in our installation as well. Dynamics CRM OAuth2 source imported from Power BI Desktop-- after saving credentials through the schedule refresh page, the credentials appear to save correctly after being tested, but the next refresh will always fail with invalid credentials errors.

 

I'm seeing the same thing for Google Analytics OAuth2 source now too but I can't confirm if it's the same problem. Google Analytics was working until just yesterday. 

 

Chris

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors