cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
anon10023
New Member

Power Query pop up windows are transparent and clear. Can't see anything.

I'm having an issue where none of the pop up windows are displaying correctly. I only see a thin outline of the actual window, but the entire content is clear and transparent so i can't see anything. I can move the window around and click the buttons if I know where it is, but I'd like to be able to actual see it. This problem seems to fix itself temporray if I restart excel multiple times or if I go into the editor and display the prompt through there, but the issue will resurface again later.

I'm running  Excel 2016 for Microsoft Office 365 32 bit, version 1902 on a Windows Server 2016 VM.

 

Does anyone know a permanent fix for this?

Here's a picture.. the thin green line is the outline of the window.
https://imgur.com/Xkk5Aof 

24 REPLIES 24
ushadevibg
Regular Visitor

HI All, I  had same issue. After a lot of struggle including  reinstalling power bi serveral times,  changing the diplay setting , version changes etc...  what worked for me is finally is clicking on "Repair" in the app settings fo power Bi. 

ushadevibg_0-1679289948174.png

 

Todd_S
Advocate I
Advocate I

Hey, all.  I think I stumbled onto a good fix for this issue.  ALT+F4 will close the blank pop-up window.  Then you can just re-launch the editor.  Since it is an infrequent (but regular) occurrence, the 2nd launch has always worked for me.  Hope this helps.

Thank you Todd_S!

Wow, you are a hero!  I thought I was going to have to crash and lose tons of work (like several times before). ALT+F4 worked like a charm. Thank you!!

Thank you so much

Thank you @Todd_S , you just saved the day for me. 

Lifesaver! You don;t know how many queries I've had to rewrite because the only way I found to clear it was to CTRL-ALT-DLT

 

Thank You!

aHorton
New Member

Same issue here. It feels more frequent and more complicated to resolve. I used to be able to do as others have mentioned, move the transparent box around, move it to another monitor, wait it out, escape it away. However, now I'm completely locked up. Going to have to kill it in the task manager.  I also do not have these issues with Power Query in Power BI, just Excel.

 

I had previously thought it was somehow related to having an extended display between laptop and external monitor with different resolutions, but I recently had this occur on a different machine that was not connected to an external monitor.

I have found that if I hit escape the blank dialog will disappear. If that doesn't work (in case I have clicked somewhere else) I click tab and then escape and repeat in that order until the dialog disappears. It avoids having to resort to the task manager or wait it out.

Thanks, this did the trick for me.

mobul
Regular Visitor

Glad to know its not just me. Sometimes its worked to select the outline and hit the escape key but usually its a job for task manager. I've found it can occur with any of the settings dialogs in Power Query Editor and probably when i have too many files open. 

 

Only other gripe I have is not being able to naviage through worksheets while in Power Query editor 

Todd_S
Advocate I
Advocate I

I run into this error several times a week.  My "fix" is to close Excel from Task Manager and hope it does not occur again a long time after I have saved.  The most common (but not only) command when this occurs is when I select 'Choose Columns'.  

paud
Advocate I
Advocate I

I had the same issue.  At the bottom of my MS Excel window, the the left of the zoom slider are the words "Display Settings."  After I clicked on that, I selected "Optimize for compatibility."  Then I restarted all MS Office programs like it said and now I can see the power query windows and contents.

Works! Kudos to you, saver! 

@anon10023, please mark @paud answer as a solution. 

That works for me too!! I really thahk you very much!

Worked for me :)... thank you

This does work but you can also drag the window to your primary display screen and it will be visible there.  The avoids the blurry display on the secondary screen that occurs when you select "optimize for compatibility".

 

I have 2 monitors, but can't confirm this. Optimize for compatibility worked like magic. Never had this bug ever again. 

Thanks, @paud! Simple fix and it worked for me.

Pfloo04
New Member

I'm having the same issue,

 

Has anyone resolved this?

Helpful resources

Announcements
May 2023 update

Power BI May 2023 Update

Find out more about the May 2023 update.

Submit your Data Story

Data Stories Gallery

Share your Data Story with the Community in the Data Stories Gallery.

Top Solution Authors
Top Kudoed Authors