Showing results for 
Search instead for 
Did you mean: 
Helper II
Helper II

Power BI And Xero, Cant see any data

Hi all,


Just testing out the Xero Content pack and I can't see any data.


When I click the dashboard I see blank tiles with the PBI logo in the center of each one.


When I click the report, we get the error:


"Something went wrong.

Unable to load report
Please try again later or contact support. If you contact support, please provide these details.


Activity ID5bbfdcb0-67b9-4a12-b8e8-fcda77ab4aba
Request ID3acd3539-1652-04df-196d-418183acdbdd
Correlation IDda3810d8-2524-85e9-4516-637313015a6f
TimeFri Jul 08 2016 11:31:57 GMT+0100 (GMT Daylight Time)
And we see a spinning 'Loading data'/'Almost done' image.
The Xero data set is unselectable.
The Xero account does have info,
The account we are using is the 'Global admin' ,
We tried a different user (Same result),
We've refreshed the page,
Logged in and logged out..
Any ideas?
New Member

Every morning I get an error message: The last refresh attempt failed. Cannot connect to the data source.


When  I log into Power BI and refresh manually it works, but I can't rely on clients manually refreshing every day.


Any ideas?


At the moment I have two dashboards, each connecting to a different Xero ledger. The idea was to roll this out to every client, but not if it isn't going to refresh automatically.


I believe that the manner in which MS has implemented connection (via public key) requires a express permission for each referesh (in practical terms). I believe that this method allows 30 minutes of access after express permission has been granted.


I'm in a similar situation - I want to have the data automatically refresh to access when I want it, not after 20-30 minutes of refreshing.

New Member

I get a similar error. 


We couldn't import data from Xero
There was an error when processing the data in the dataset.
Please try again later or contact support. If you contact support, please provide these details.


Data source type
Data source error The parameter is expected to be of type Text.Type or Binary.Type.


Any ideas welcome.

Super User
Super User

I assume that you have looked at the Xero for Power BI content pack help page?


If so, I can't be of much more help as I do not have a Xero account to test with. The only caveat I noticed in the above post was:


"If your content pack fails to refresh, please check if you have connected to the same organisation more than once in Power BI. Xero only allows a single active connection to an organisation and you may see an error indicating your credentials are invalid if you connect to the same one more than once."

@ me in replies or I'll lose your thread!!!
Instead of a Kudo, please vote for this idea
Become an expert!: Enterprise DNA
External Tools: MSHGQM
YouTube Channel!: Microsoft Hates Greg
Latest book!:
Mastering Power BI 2nd Edition

DAX is easy, CALCULATE makes DAX hard...

I did read all of that, yes. It seems that after a few hours it just started working..

Helpful resources

PBI Sept Update Carousel

Power BI September 2023 Update

Take a look at the September 2023 Power BI update to learn more.

Learn Live

Learn Live: Event Series

Join Microsoft Reactor and learn from developers.

Dashboard in a day with date

Exclusive opportunity for Women!

Join us for a free, hands-on Microsoft workshop led by women trainers for women where you will learn how to build a Dashboard in a Day!

MPPC 2023 PBI Carousel

Power Platform Conference-Power BI and Fabric Sessions

Join us Oct 1 - 6 in Las Vegas for the Microsoft Power Platform Conference.

Top Solution Authors
Top Kudoed Authors