Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
icerdeira
Frequent Visitor

Option Set problem using Dynamics 365

Hello,

 

I have created a new option in a set of Dynamics 365 options. Until now it worked correctly and when I added a new option, it generated a column "name" that I used in my report. I have created a new option and it resolves the name as "null".

 

I have tested and every time I create a new option, it appears as null.

 

Thanks.

 

Best

 

icerdeira_0-1711971553453.png

 

icerdeira_1-1711971606508.png

 

 

 

6 REPLIES 6
MikeGerany
New Member

We are experiencing the same issue and I am glad I found this kind of still open topic here which is from 2024...And I hope it is still monitored...When I push Data into Power BI from our MS 365 Environment (Dataverse) the option set names are no longer populated. This means - older option set names from the same option set are populated to Power BI and all recently added new values to this option set are only populated as their numerical value in Power BI but its name value returns null. I have tried that on different tables, different workbooks, different connectors and also with Direct Query and Import of the data. 
For me it seems as if something was changed (more or less recently) on the Microsoft side which does not populate the newly added values but does so for older option set entries. I also checked if I did anything wrong on the optionlist itseld in PowerAutomate but there is not so much one can mess up by just adding new values to an existing option field list...As we are working with quite a number of option sets in our company this is an increasing issue and I hope there is a solution or workaround or fix. 

Fun Fact....after DAYS and WEEKS of searching I have found the solution (at least for me) in another Post here here in the Forum...Yet so simple once you know what was the root cause. Usually I added new values directly in the column in the table and did not add the table in a solution, added the values and published the solution. Never felt it was necessary...well...seems it is. Here is the original blog post with the solution in...I added the column with my option set in to a solution, published it and tested a reload in Power Bi and all the value names were published...WOW...

https://community.fabric.microsoft.com/t5/Desktop/Can-t-see-the-display-value-of-a-choice-column-fro...

 

RossEdwards
Solution Specialist
Solution Specialist

Could you be working from a cached optionset?  I.e. is the option set in another Query that holds the contents that you are left joining in?  If so, could you go to this other query and 'refresh preview' to see if the new option turns up?

 

Alternative, did you add this new option to the same Dynamics environment that is the source of your query?  I.e. did you add it to a DEV environment but you are connected to your TEST environment?

The query is up to date and I am working on the production environment. I have tried to create a new BI report and it still does not work. Every option set I add returns the name as null. 

 

Thanks

What connector are you using in your Source row?  Is it CommonDataService.Database(<YourURL>)?

 

I'm wondering if you are using an older connector.

I'm using the Dataverse conector.

icerdeira_0-1712138027781.png

 

Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors