Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Anonymous
Not applicable

OLE DB or ODBC error: Exception from HRESULT: 0x80040E4E

Hi PBI friends!

 

I'm receiving this error message "OLE DB or ODBC error: Exception from HRESULT: 0x80040E4E" when trying to refresh data that I loaded into my Power BI model from Google Analytics.

 

jovalle_0-1655245804218.png

 

 

Has anyone seen this Open Database Connectivity (ODBC)/Object Linking and Embeding Database (OLE DB) error message before?

 

Thank you so much in advance for your help! 

 

Best,

 

JP

1 ACCEPTED SOLUTION
Anonymous
Not applicable

Hi,

I actually went in and found the error within Power Query, got ride of the error, then reloaded it and it worked!

 

Thanks for the call out!

 

Best, 

JP

View solution in original post

10 REPLIES 10
Sanjay_GB
Frequent Visitor

Has this error got resolved? I am facing similar error but don't see any sollution. Can anyone reshare the sollution here?

Error.jpg

Hi.... u may try this.. before I apply/load the Power Query, I just remove connection between the data (data connector/relationship) first from the model view. When I apply it working fine, then I just manually create the connection back.

 

Some of them also said that we can found the error within Power Query after load, need to get rid of the error, then reloaded it.

rohit_singh
Solution Sage
Solution Sage

Hi @Anonymous ,

Please open power query and navigate to the queries that are showing the error. Check each step within the query to find where the error is, and share the shareshot.

Kind regards,

Rohit

Anonymous
Not applicable

Hi,

I actually went in and found the error within Power Query, got ride of the error, then reloaded it and it worked!

 

Thanks for the call out!

 

Best, 

JP

Please remove this comment as a solution.  It is not a solution as it gives no indication as to what caused the problem.

I am facing the same issue but there is no issue showing in the power query!

How do I resolve this, though when I click on appy changes it starts loading the row but taking long time and in between this error pops up.

Did you have any luck figuring out what was casuing your error?  I'm having the same issue, Power Query works fine but when I apply I get this error.  The data is coming from a folder containing Excel files which are then combined.  Files are identical in structure and there aren't any corrupt ones or anything like that.

Hi, I don't know if this can help u guys but for mine, it works. I just delete the data connector/relationship first from the model view. When I apply it working fine, then I just manually create the connection back.

Ok sağol

Hi @Anonymous ,

That's great news. Happy to help! Please mark your answer as the solution to help others as well.

Kind regards,

Rohit

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Top Solution Authors
Top Kudoed Authors