Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
iFrech
New Member

OData error with Dynamics CRM Online

I'm trying to connect PowerBI desktop to an online Dynamics CRM instance. However I'm getting the following error: 

 

DataFormat.Error: OData&colon; The given URL neither points to an OData service or a feed: 'https://<xyz>.crm.dynamics.com/XRMServices/2011/OrganizationData.svc'.
Details:
https://<xyz>.crm.dynamics.com/XRMServices/2011/OrganizationData.svc

 

where <xyz> is the actual tenant. I have previously been able to use the Get Data function from Dynamics CRM online with another tenant and been able to retrieve the data. However, this specific URL gives me trouble. Could it be some sort of configuration on the CRM environment?

 

Also: I never get prompted for user/password information.

1 ACCEPTED SOLUTION
TPalmer
Microsoft Employee
Microsoft Employee

If you weren't prompted for a username/password it's possible you already had credentials stored. You could try deleting your credentials and connecting again, at which point you should be prompted to login and can choose Organizational Account. Sometimes that error ("neither OData service or feed") can be caused by connecting with the wrong credentails - the feed will redirect you to a login page instead of connecting to the feed.

View solution in original post

31 REPLIES 31

Thanks,  it worked for me

Greetings,

 

The solutions is still valid for Dynamics 365, in April of 2019.

 

Thank you.

Thanks Chris the API URL worked

This worked for me. We run Dynamics CRM online in the government cloud, BTW.

No matter what we try, remove credentials, different syntax, copy from our CRM online, everything we can technically effect and we get this error over and over. Does anybody have any reasons they can think of why this is not working or can help resolve it?  

 

Details: "OData&colon; The given URL neither points to an OData service or a feed:

 

CaptureCRMPBI.PNGI too have problems with connecting to Dynamics CRM.  I tried logging in with Organizational Account and got this error.  Can anyone help?

 Hello Lucy, 

 

I was having the same issue you seem to be having. Check the Organization Service URL that you copied from your CRM Customizations Page, eg: 'https://<org>.crm.dynamic.com/XRMServices/2011/OrganizationData.svc'.

 

The link that was in my CRM left out the word 'Data' after Organization. I simply typed in 'Data' back in and it worked for me. Hope this helps. 

 

hvoncannon you are a star!

 

I have been trying for months to get connected to CRM and who would have known that the word "Data" was all it needed.

Thanks a million.

Awesome! Glad I could help. 

 

Thanks for the help from this solution. Saved me from a major headache.

Thank you. This totally worked.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors