Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
cuonglt
New Member

How to change data type to deicmal when using power query write data to dataverse

Hi,

I'm trying to write a table to Dataverse using power query.

My table has the "Value" column which is very large number (up to 100 billion).

On the ETL process, I set the "Value" 's data type as Decimal number.

2023-02-03_20-24-17.png

 

Then on this window, its set to floating type and doesn't allow me to change back.

2023-02-03_20-28-53.png

 

I tried to run that dataflow and got this error message

2023-02-03_20-31-43.png

 

I tried create the destination table before run the flow, set the "Value" data type as Decimal (on dataverse), then re-run the flow but still got the same error.

 

Any advises? 😄

1 ACCEPTED SOLUTION

Hi @cuonglt - it appears that to need to change your PowerApps (dataverse) table. The target column is set in INT.  This needs to be changed to BIG INT to accept larger numbers.  If this still doesn't work, the column will need to be set to TEXT.  Please note again, this change needs to be made on the Dataverse table not in the Power Query data type.

View solution in original post

4 REPLIES 4
Daryl-Lynch-Bzy
Resident Rockstar
Resident Rockstar

Hi @cuonglt - rather than "Decimal Number" (per the first image) is the Data Type option for "Fixed Decimal Number" available.  This will force the Power Query to use Currency.Type, and this might make Dataverse treat the column as Decimal or Money Type instead of Floating (I know it seems illogical).  However, I would suggest using Whole Number data type if the numbers are larger than 100,000,000,000

 

Column data types in Microsoft Dataverse (contains video) - Power Apps | Microsoft Learn

Data Type Size Limits 

 

Thanks you for ur response, i tried to using Whole Number data type...

2023-02-06_8-57-43.png

 

 

but got this error T_T''

2023-02-06_9-38-31.png

 

 

Hi @cuonglt - it appears that to need to change your PowerApps (dataverse) table. The target column is set in INT.  This needs to be changed to BIG INT to accept larger numbers.  If this still doesn't work, the column will need to be set to TEXT.  Please note again, this change needs to be made on the Dataverse table not in the Power Query data type.

Thanks you so much;

Setting the data type to BIG INT didn't help. But setting to TEXT worked.

This saved my day, thansk you 😄

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors
Top Kudoed Authors