Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Ronnie7
Helper II
Helper II

Gateway not available

 

Hello,

 

I have an enterprise Gateway installed and configredon a Windows Server.
I have added a new data source on this Gateway -  created a data source (ODBC - IBM Netezza database, connection string DSN=<database name>) and was able to successfully connect (I can see message connection successful).
 I have a report that is connecting to this database using a Generic ID. Upon publshing the report to the cloud and going to settings, under refresh history or schedule a refresh  the "use on-prem data gateway is greyed out". I'm a user who can use this DB to publish reports. 

ON the same server where the Gateway is installed i have configured the ODBC Databse for both 32 and 64 bit,  using the exact same connection string and exact same generic ID and password as the define in the data source on the Gateway, connection tested successfully. 

 

Why is the  on-prem data gateway disbaled then?
Anything i'm missing?

 

Any help would be appreciated 

1 ACCEPTED SOLUTION

@Anonymous

Issue has been resolved!

Problem was that for some reason it didn't like connecting to Netezza via ODBC altough the ODBC driver for Netezza is installed correctly and have a system dsn configured for the database. 
I have created a new data source on the gateway and connected directly to IBM Netezza rather then via an ODBC connection. 

I can now see the enterprise gateaway and can refresh the data...

 

There is something it doesn't like when connection via an ODBC driver... 

View solution in original post

4 REPLIES 4
Anonymous
Not applicable

In the "Date Source Settings" for your Power BI project.  Is 100% of your tables coming from a source listed in your gateway?

 

You can find this concise listing of sources by clicking the arrow under "Edit Queries" and selecting "Data Source Settings".  This will give you a listing of every data source in this project.  Your gateway must contain all of them, with identical connection strings.  This meaning that "C:\Folder\File" is not the same as "\\Server\Folder\File" even if the destination is phyiscally the same.

@Anonymous

Hi,

 

I double checked the data sources for the PowerBI project. only one  data source  - IBM Netezza. Double checked the connection string and user name - all identical in the project and identical on the gateway settings for that data source. Still the Gateway is greyed out and unavailable. 

Anonymous
Not applicable

Can you please provide some screen shots for us?  Hopefully something will stand out to us as to what is missing.

@Anonymous

Issue has been resolved!

Problem was that for some reason it didn't like connecting to Netezza via ODBC altough the ODBC driver for Netezza is installed correctly and have a system dsn configured for the database. 
I have created a new data source on the gateway and connected directly to IBM Netezza rather then via an ODBC connection. 

I can now see the enterprise gateaway and can refresh the data...

 

There is something it doesn't like when connection via an ODBC driver... 

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors
Top Kudoed Authors