Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
kcantor
Community Champion
Community Champion

Expression.Error: The key did not match any rows in the table

I have a data set that has refreshed successfully in the past. It was built 3 days ago and refreshed fine for two days. Now I cannot refresh it either on the desktop version or from services. The error reads Expression.Error: The key didn't match any rows int he table. Other tables return the error message Load was cancelled by an error in loading a previous table. I tried to delete the problematic table from the data set with plans to re add it later. When I deleted the problem table, a second table threw the same error. I removed it too and a third then erred.  It is a domino effect. All tables are failing one at a time. The tables, however, are fine. I can use them in other documents and in PowerPivot. any ideas?

A coworker updated her version and the gateway and is getting the same error. This was built in a group and resides in the group folder.





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




1 ACCEPTED SOLUTION
tonysellars
Advocate II
Advocate II

Ran into this issue myself within the Power BI Desktop and was able to resolve the issue through the following:

 

  1. Select Edit Queries from the menu to open the Query Editor
  2. Use the left hand menu to select one of the queries having the issue (will have the triangular warning sign)
  3. On the applied steps menu at the right select the source step.
  4. In the top menu bar, select Refresh Preview.

In my case there were several queries having this same issues and the steps above resolved each of them.

 

Hope this helps -

View solution in original post

45 REPLIES 45

I also had this problem and the reason is that every time I download the raw data from salesforce, the worksheet is given a different name, so the worksheet name needs to be updated in each query under 'navigation'. I have only had this issue since importing xls files rather than csv's, so might just go back to csv's.

Thak you. It solved my problem but do you know why it happened in the first place?

Nothing changed - 1 day it worked - the next day refresh bombed with this message

The refresh preview approach did not resolve the issue for me.

I created new connections to the same data source and then used Advanced Edit to copy the new connection strings to my original tables.

Has Microsoft acknowledged this is a PowerBI Desktop issue ?

Anybody understand the root cause ?

 

Hi Tony,

 

I have the same error but I am using power query in Excel. I am using a personal gateway, here is my error message below:

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors
Top Kudoed Authors