Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Helper I
Helper I

Dataset refresh asks for installation of personal gateway, when on-premise gateway is running

Data Source Settings of original pbix file:



Picture of successfully running data source:



I go to refresh the uploaded pbix data set and get this:



Cannot find any documentation on this error.

Frequent Visitor

I'm experiencing this exact same issue, with the slight modification in that I'm using a DSNless connection string.  I'd also be interested in a fix.

Has anyone heard any more about this?  The "work around" of publishing the pbix first then creating the gateway connection is counter intuitive however it also is not workable.  It works for the first pbix you publish however when you try to publish the second one (gateway connection already created at this point) it won't publish.  That dog won't hunt as they say.

Community Champion
Community Champion

@CLEARIFY i think i have come across this issue before and the way it was solved is by deploying in below steps.


1. Take out gateway data sources in power bi service

2. Create pbix file to data source

3. publish pbix file to service

4. add data source to gateway

5. refresh dataset in power bi service


also ensure in power bi desktop you've signed out under File -> sign out and then when you publish it will ask you for credentials and enter it then. this step may or may not have anything to do with this error but has worked for me in the past and so putting it here.


i haven't been able to find any exact reason or the cause except that trying out in above steps have worked for me. i certainly have seen that error before and believe it is to do with the steps a report is published in. 

Well that works. 


What was interesting was that I couldn't load any other pbix files - even logging out before uploading.  The only way this seems to work is if the data source doesn't exist berfore publishing the files.


So.... this is not ready for prime time yet.


How do we report this bug for Microsoft to fix - this is cretainly repeatable



Did this issue only happen to ODBC data source? You said "couldn't load any other pbix files - even logging out before uploading", have you tried to upload files in Power BI Service by Get Data-> Local Files.


After publishing the reports to Power BI Service, please check which gateway is used by the dataset. You can change it to use on-premises data gateway which you have configured before publishing.





Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

The premise of our product (QQube™) is to elminate the need for using cumbersome connectors, becuase of the need to know tables, relationships, connecting strings, reverse engineering etc.


We have a traditional star schema data warehouse for QuickBooks, and have created 'shells' for each subject. (Subjects are independen, and minimize any need to create "cross FACT" analysis.)  We install several ODBC drivers, and have shells for many products, e.g. powerpivot, access, crystal reports, etc. so that people can just open up a shell and never once have to deal with a connector. They don't have to spend time figuring out the nuts and bolts - they can just start dragging their fields into the canvas.


All shells for all products use the same ODBC connectors, so that if one person creates a dashboard/pbix file on one desktop, all they have to do is send the pbix file to someone else who has our product, and then they can refresh with their own data - never once, having to create a new connection of any sort - or having to recreate the dashboard/layout.


So once we create the shells using one of our ubiquitous ODBC connectors, anybody should be able to (a) install the on-premise or personal gateway, then (b) create something using one of the shells we have provided, and (c) hit the publish button to get it going. (Obviously they have to create the PowerBI Pro account before doing so).


We have checked, and double checked, and somebody in the community found a workaround, which intimates that there is a bug.  The workaround is to upload the files FIRST, then install the on-premise gateway; then everything works fine.  This is repeatable.  


The problem is, we can't upload any other shells, after the gateway is in place.


And no, the Get Data>Local Files also didn't work.


Several customers have reported that using the personal gateway works most, but not all, of the time.


We would like to be able to give customers simple instructions to use our product seamlessly with PowerBI Pro to refresh their data automatically, but unfortunately, we will have to wait until this is fixed - or somebody can find the nature of the problem.


Not trying to be "salesy' or create a pitch here (we just want this to work), but if you want to see how we interface with your product you can go here to one of our guides:




I reproduced the issue on my side. And I already reported it internally, will keep you updated once I get any feedback.


Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors