Forum Discussion
RunTimeTransferContext Error in Fabric Pipeline When Copying Data from Lakehouse to Warehouse
- Anonymous1 year ago
Hi RoopanshGupta
Thank you for reaching out microsoft fabric community forum.
This is an intermittent issue, and we have not been able to identify the root cause so far. If the issue persists in the future, we recommend raising a high-priority support ticket for immediate assistance.
How to create a Fabric and Power BI Support ticket - Power BI | Microsoft Learn
If this solution helps, please consider giving us Kudos and accepting it as the solution so it can assist other community members.
Thank you.
Thanks for sharing your experience - it’s reassuring to know we’re not alone in encountering this issue.
For us, this error came out of the blue on 21 May. The pipeline had been working flawlessly for months, but suddenly, it started failing, that too on specific tables within this particular pipeline, showing the exact error I described earlier. We tried everything the entire day: verifying data types, checking configurations, recreating activities, etc., but nothing worked for those specific tables.
What's frustrating is that, today, on 22 May, everything is mysteriously working back to normal, almost as if nothing had happened.
While I’m glad the issue resolved itself, this is not acceptable, especially for productionized pipelines. Such sudden disruptions can have significant downstream impacts, and the lack of visibility into the root cause or any acknowledgment from Microsoft makes it even more concerning.
To add to the strangeness, today (22 May), we encountered a new Fabric-exclusive error during the retry mechanism. Here’s the screenshot of the error:
Fortunately, our retrial mechanism kicked in, and the error didn’t appear in the second attempt. But these intermittent and unexplained errors need to be addressed urgently by Microsoft.
At this point, it seems plausible that there are backend changes causing these issues, as nothing on our end has changed. This lack of stability undermines confidence in the platform for production workloads. I’m considering raising a support ticket for this, but seeing how others are already burdened with multiple ongoing tickets, it would be great to have some clarity or acknowledgment from Microsoft on whether they are aware of these issues.
All the best buddy! Let’s hope this gets resolved for good soon.
- HMSNemanja1 year agoFrequent Visitor
Thank you for sharing!
First of all, I'm happy that your issue seems to have resolved itself, although I fully agree with you that it's not really acceptable.I'm not sure how long you've been running your production workload Fabric capacity, but errors like this have not been completely uncommon for us during last year (at one point there was backend issues with the live livy session, which resulted in us not being able to run our Notebooks at all for 3 days for example).
That being said, the second error you're describing could actually be related to synchronization issues between your Lakehouse artifact and it's SQL endpoint.
We have had similar issues when reading data from SQL endpoints, the issue has so far always been related to meta-data inconsistencies when reading the parquet files from storage.
One such scenario, for us, has been if we modify a large number of records in a table in our Silver Lakehouse, and immediately try to read the changes downstream in our Gold Lakehouse (we use shortcuts between the two).
It usually solves itself after a couple of retries, as the SQL endpoints does automatically refresh within specific intervals, but we've instead added a permanent solution to this by always refreshing our SQL endpoints in a pipeline action (notebook invocation).
It could also be related to soft-delete policies (if you have that enabled) due to retentation period.Overall the issue is very sporadic and only appeared randomly for us, but we've not experienced it since we implemented our solution.
FYI: I just ran our pipeline and can confirm that it works now as well.Most likely a transient error in Microsoft's backend, and I strongly doubt we'll get an official statement on this.
Best of luck to you!