Forum Discussion
Pipeline fails to start: "internalServerError executing request"
- 2 years ago
Hi JP_Wisco
Apologies for the delay in response from my end.
Following up to see whether the issue got resolved or still you are facing the issue?
The error "Internal Server Error - Executing requests." could be a transient network issue.
If the issue still persists. Please reach out to our support team so they can do a more thorough investigation on why this it is happening. It's difficult to tell what could be the reason for this performance. If its a bug, we will definitely would like to know and properly address it.
Please go ahead and raise a support ticket to reach our support team:
https://support.fabric.microsoft.com/support
After creating a Support ticket please provide the ticket number as it would help us to track for more information.
Thank you.
Thank you for the response. I hopped into the pipeline to provide a detailed response and initiated a manual run while I was at it. The run kicked off without issue and fully succeeded 20 minutes later. After three straight days of scheduled fails, I have a manual success and was able to restart the schedule without issue. I haven't made any changes to the pipeline, sourcess or destinations beyond unpublishing the in-development Power BI reporting that was built on this data. I guess I'm cured until it happens again?
- Beyond the copy of my original pipeline, and now my original pipeline, I've had this error in one other unrelated pipeline.
- This pipeline starts with two Lookup activities and a set variable activity grabbing info from lakehouse tables, a notebook to delete older .json files in a datalake directory, and then a ForEach with a copy activity to make a series of API calls and save the .json files to my directory. The pipeline finishes up with a notebook to rebuild my reporting delta tables and a couple of final activities to send me an email and make a Teams post if the refresh fails.
- Sources for the lookups are delta tables in my datalake, source for the copy is a software vendor API, and the source for my notebooks are the datalake file directory. I had the pipeline scheduled to run every 15 minutes, dialed it back to every 60 minutes to monitor after a notebook refactor, and was observing it consume less than 3% of our trial capacity compute. I have some additional refactoring scoped to target 5-minute refreshes at 2.5% capacity, but that's tables while I work on the Power BI reportin.
- The last two activities, Office 365 Outlook and Teams are noted as being in (Preview). I previously removed dataflow activities from all of my pipelines over four weeks ago. They were functioning, but felt clunky with schema change error when loading to delta tables. It would also take five to fifteen minutes for a dataflow to build a single table from my data, where a notebook now rebuilds the entire reporting database in less than two minutes.
I made a copy of the pipeline to test
When making a copy of a pipeline and you have a PipelineName system variable in your activities , Teams activity in my case, this error occurs. Removing the PipelineName variable and re-adding it resolves the issue. I'm assuming the pipeline renaming causes the issue but didn't fully test scenarios.