Forum Discussion
How to link SQL server in private network from pipeline in Fabric?
Hi, Winnie20242024
Depending on the information you report as an error, the cause could be Azure SQL Database is set to deny public network access. This requires to use managed virtual network and create private endpoint to access.
Recommendation:
-
If you insist on disabling public network access, use managed virtual network integration runtime and create private endpoint. For more information, see Azure Data Factory managed virtual network.
-
Otherwise, enable public network access by setting Public network access option to Selected networks on Azure SQL Database Networking setting page.
Best Regards,
Community Support Team _Charlotte
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.