Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
v_mark
Helper V
Helper V

Row level Security on a Report Shared in Microsoft Teams ( Not Working )

I have a report that has RSL implemented. I Check it Power BI Desktop and Service works totally fine. Whenever I add it on teams looks like the RSL is not working. I tried to ask those users to go directly in the service under shared report and we are getting the expected result. Now I don't know if it's a  Microsoft Teams issue or not. Considering whenever they access the service everything works fine.

 

 - All users have a pro license 

 - Report is on a legacy workspace with no PBI premium content

 - no one of them is part of the workspace (member) 

 

Any suggestions on how to resolve it? 

 

 

7 REPLIES 7
BKBO04
Frequent Visitor

I have the exact same problem here. Seems to me there hasn't been found a solution yet? I embedded the report in Teams Desktop with "add a tab".

 

v-rzhou-msft
Community Support
Community Support

Hi @v_mark 

Did you use add a tab to embed your report into teams with the user in team desktop?

1.png

For more details: Embed Power BI content in Microsoft Teams

If this still couldn't help you solve your problem, please show me a screenshot of your issue.

 

Best Regards,

Rico Zhou

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly. 

v_mark
Helper V
Helper V

Hi @v-rzhou-msft

 I tried both up to even sharing the link only but no luck. What I notice is every time users will go directly to the service. Everything works well. Seems some issues between service and teams

I tested as well and was not able to reproduce any issue. 

 

Best solution to nivestigate would be to open a support case to track down what's happening in your case. 

 

If you provide sample data, the RLS rule that is not being enforced, and the role assignment logic you use it may help narrow down the issue. 

 

It's also important to know is if "RLS is not working" means "the user can't see data they should be able to see" or something else. 

 

Are users using Teams desktop or Teams web? 

@lukaszp -  Users are using Teams desktop 

v-rzhou-msft
Community Support
Community Support

Hi @v_mark 

How did you add your report into teams, attach or embed?

I try to embed my report into my teams and RLS will work well for users in teams.

In teams:

1.png

In Share:

2.png

For more details: Embed Power BI content in Microsoft Teams

 

Best Regards,

Rico Zhou

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly. 

v-rzhou-msft
Community Support
Community Support

Hi @v_mark 

How did you add your report into teams, attach or embed?

I try to embed my report into my teams and RLS will work well for users in teams.

In teams:

1.png

In Share:

2.png

For more details: Embed Power BI content in Microsoft Teams

 

Best Regards,

Rico Zhou

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly. 

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Power BI Header Change

Power BI Header Update

Read about the exciting updates for the Power BI forum.

Top Solution Authors
Top Kudoed Authors