Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

what if parameter of increment 0.1 keeps changing the inputted value

Hello, 

I created a what if paraemter-numerical range, fixed decimal number from 0-300 increment of 0.1 eg 1.1,1.2,.....,29.9,30,30.1,.....,299.1 etc.  I added it to a slicer and put the slicer settings to single value. However, when I type a value in the slicer  eg 70, it changes my inputted value to 70.1, sometimes it subtracts 0.1 instead eg input-69, value-68.9. 

I have no idea why its doing this, it seems the fact that its a single value setting is causing problems since when i change it to dropdown or vertical, it doesnt mess with the value at all. Howver, its from 0-300 in 0.1 so its a long list, so id like to avoid using the other slicer settings if possible. 

Any help is appreciated, thank you! 

Status: Investigating

Hi @Ayinkeokin ,

 

Can you provide detailed version information so we can reproduce the issue? We'll get back to the product team as soon as it's acknowledged as an issue!
Thanks in advance!

 

Best regards.
Community Support Team_Caitlyn

Comments
v-xiaoyan-msft
Community Support
Status changed to: Investigating

Hi @Ayinkeokin ,

 

Can you provide detailed version information so we can reproduce the issue? We'll get back to the product team as soon as it's acknowledged as an issue!
Thanks in advance!

 

Best regards.
Community Support Team_Caitlyn

Ayinkeokin
New Member

Creating Parameter 0-300, increment 0.1Creating Parameter 0-300, increment 0.1Create single value slicer for the parameter and type in any value from 0-300 eg 20Create single value slicer for the parameter and type in any value from 0-300 eg 20Power BI auto-corrects typed value to - typed value+0.1, once you click enterPower BI auto-corrects typed value to - typed value+0.1, once you click enter

 

 

 

 

 

 

 

 

p5.PNG

 

83466ba5-a03e-4e23-93c2-bb98c869f734.png

 

I created a numerical range parameter from 0-300 with an increment of 0.1. Then created a slicer to load the parameter too. The parameter uses function [ Parameter = GENERATESERIES(0,300,0.1) ]. The slicer setting is set to single value where you should be able to type in a value between 0-300. The two examples above show me typing 20, click enter, auto-corrects to 20.1; the I type 90, one would expect 90.1 at the very least, instead, I received 89.89. So some of the numbers between 0-300 work fine eg 50 resulted in 50.0, while others get 0.1 added and some subtracted. 

Please let me know if this is sufficent as more information. Thanks!