Showing results for 
Search instead for 
Did you mean: 

Fabric is Generally Available. Browse Fabric Presentations. Work towards your Fabric certification with the Cloud Skills Challenge.

refresh failures

Experiencing a metric ton of refresh failures this morning that site intermitent issues. Error message is:
Failure details: The last refresh attempt failed because of an internal service error. This is usually a transient issue. If you try again later and still see this message, contact support.

I understand transient issues but I am now at 18 failures. Is there a larger issue? Nothing on the support page.

Status: New
Not applicable

@kcantor try clearing the Cache for all 3 things again and set the "Maximum allowed (MB) to 0 and then try publishing.



Not applicable

@Anonymous I tried your fix with clearing the catche but it didn't work.

Community Champion


Thank you for the suggestions. I have done all of that. I have even disabled Q&A all together on some reports. This has been an ongoing issue for me lately and Microsoft is simply not helping. In fact, the failures this morning simply needed to be manually refreshed on the service.

I should not have to go to the service and manually refresh three or four reports each day. Microsoft should fix the issue. Also, Some reports, I have refused to clear the cache on and republish because I manage a metric ton of reports and those reports will successfully refresh manually and/or automatically refresh the next day. This is a rolling issue and I am using this thread to call attention to the fact that Microsoft refuses to admit there is a problem and fix it. 

Going in an manually doinking with each model to clear cache, wash, rinse, repeat, and republish is simply not feasible for those of us who manage the reporting capabilities for large companies.


Regular Visitor

@kcantor Did you log a ticket with PowerBI support and get any response? I logged a ticket over 2 weeks ago and front line support just said 'no update from product group' each day but I don't even get updates from them now. We have paid support when we don't need support (They do), it's a joke. Also no phone number to call, just waiting around for weeks for email. HOw can they bang on promote the Power Platform so hard when it has underlying issues and a lack of support.

Frequent Visitor

I am having the same problem, we have a very simple excel file stored in sharepoint used for a dataset. Less then 3000 total records in that excel file. Employees created 20-30 reports online in the workspace the dataset resided in by creating the reports in the online service method. The last time the excel dataset data was updated was friday 3/12. The scheduled refresh completed properly 8 times between friday and sunday when it started failing Sunday afternoon with "The last refresh attempt failed because of an internal service error. This is usually a transient issue. If you try again later and still see this message, contact support." I can refresh the data in the.pbix local file, i can deploy the dataset to a different workspace and it refreshes fine and I also can deploy the same dataset that wont refresh to the same workspace it wont refresh in with a different name and all scenarios work. The problem is the employees will have to recreate all the reports if the dataset changes locations or sources because of the method the employees used to create the reports. Its very frustrating that nothing changed on our end, the issue says to contact microsoft and microsoft is clueless with why it is occuring. 

Frequent Visitor

Having similar issues. Currently my company has 4 big datasets running. 1 of the datasets seems to be corrupt in some weird way and will not refresh anymore. No changes were made in the model and local refresh is not an issue. Can't republish the dataset as the refresh is still running in the background in the service for some reason, it is marked as 'timed out' and the refreshes before that are 'transient errors'. 

Replacing the dataset will be a nightmare as there are 10 reports linked to it and many people have created bookmarks for example. Tried the solutions in this thread and many others (clearing cache etc.). 

Resolver III

I've never done incremental refresh b/c the volume of data @ my org simply isn't that large; however, I set this up for some of my reports that were failing to refresh & they are now refreshing w/o issue.


This might not be viable for some & others may have already done this.

Community Champion


Are you able to download the .pbix from the service and refresh it on your computer? If so, download it, refresh it, and save it over the existing original file on your desktop (make a backup copy of course prior to doing that). Then use the get data function from the service. When the service wants to know if you would like to replace the model, say yes. That will put a fresh, refreshable copy in the service. Next, go to your gateway and remove all existing gateway connections for that model (when you hover over the connection, three dots will appear allowing you to remove it from the gateway). Then readd the connections necessary and try to refresh again. 

This method will not cause you to lose any reports while allowing you to replace the model.

Good luck, I hope this helps.

Community Champion


Good morning! STill having the same issue. No detail provided except it is an internal service issue. See detail below. Are they doing planned maintainence today?

Scheduled3/19/2021, 8:00:29 AM3/19/2021, 8:08:03 AMFailedThe last refresh attempt failed because of an internal service error. This is usually a transient issue. If you try again later and still see this message, contact support.
Activity ID:7a8550a1-16fb-495c-b324-c17c6e04b284
Request ID:3f05463b-5076-4f35-aa16-e18e54969f87
Time:2021-03-19 12:08:03Z
Frequent Visitor


Had already tried the 'Get Data' function in the service with the refreshed local pbix. Outcome: it says "The file has been updated" when in reality no new data has been uploaded. Dataset does not use the Gateway, all files are in the cloud (Sharepoint). Other datasets we have running also make use of the same Sharepoint and files and have no issues whatsoever. 

Just tried doing the 'trick' you mentioned with a pbix copy downloaded from the Service. Same result. 

To be honest, these workarounds/solutions do not make it sound like I am working with the Gartner Magic Quadrant leader of Business Intelligence tools :-).  I am 100% sure this is an issue on Microsoft end, as dataset have been running fine for months. 

Thanks for the help!