Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

"Chiclet Slicer" in Power BI App is blank since this week

I have an issue with the visual "Chiclet Slicer" in reports bundled in a Power App.
The report published in Power BI Service shows the visual:

But the same report published in Power BI App look like this:

The Power BI App worked fine since months, but is broken since this week.

Status: Delivered

Currently this issue about custom visual display seems to be fixed. Now it works fine in my side.Please check it again in Power BI Service.


Best Regards,
Community Support Team _ Yingjie Li


Regular Visitor

I have the same problem.


How can we fix this?

Regular Visitor

We have been having similar issues the last couple of days and it's across all platforms (desktop, iPad, mobile phone). We redeployed one report and that seemed to work. Howevever, it would be good to know if there is a reason/explanation for this issue suddenly appearing. 


New Member



I have the same problem, and a lot of customers on the app !!!!


CTRL + F5 will reload the slicers and show them in the app, but it wasn't like this before!






Helper I

I have the same issue in mobile app when you log out and login the issue gone for first open the report and comes again in the next time you open the report  

Frequent Visitor

Ran into the same issue starting last night with our app.  All Chiclets look fine in the workspace but in the app they won't load unless you refresh the browser.  Would love a solution so we don't have to add a note on every page stating the workaround for slicers not loading. Our team tried republishing, updating the app, restarting computers and clearing cookies with no luck. The only things that fixes it is refreshing the browser for that report once you are on it. 

Regular Visitor

I am having this exact same issue with a Text Filter visual.  Just this week the visual is not showing up on the reports.  I tried re-publishing the report that did not work.  The Ctrl + F5 option that another user posted does work, thanks for that work around, but there is an issue that needs resolved. 

Advocate II

Apparently, all custom visuals are affected: Browser refresh needed CTRL+F5 to show a custom visual

Community Support
Status changed to: Accepted

Simliar issue has been submited internal(ICM: 273897701)


Please see the update on the support page:

Power BI customers accessing reports with approved custom visuals while using Power BI Apps, the Mobile app (Android and IOS) or a UWP app may encounter issues rendering the custom visuals in the reports.

As a workaround, users can refresh the report page. Engineers have identified the root cause and a fix is expected to be deployed by end-of-day 11/24/2021


Best Regards,
Community Support Team _ Yingjie Li

New Member

I have the same problem with th "Chiclet Slicer", I can view them in the report but not in the app where the report ist assigned.

The slicers disappear on each page

New Member

Hello TEAM , I need your support