Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

pii column does not exist in the rowset

My dataset has being refreshing in the service fine for two months. Since earlier today I have this error:

The '<pii>SOME_COLUMN_NAME</pii>' column does not exist in the rowset.

When I refresh the same dataset in the desctop - everything is refreshing fine.

After I upload the refreshed dataset to the service and refresh it there again - it refreshed fine.

I didn't change anything in the desktop, neither I got any power query error.

I also cannot tell whether the column disappeared from the dataset or not, because I have several tables with columns with this name.

But even if a column dissapeared from the raw datasource (ODBC), it is not actively addressed in any step in the power query.

 

Status: Investigating
Comments
v-chuncz-msft
Community Support
Status changed to: Investigating
 
v-chuncz-msft
Community Support

@michaelsh 

 

It seems the column has been removed from the underlying source. Refresh in Power BI Desktop is needed to reflect any metadata changes. After that, you may publish it again.

michaelsh
Kudo Kingpin

Sorry, but I do not agree to the "Refresh in Power BI Desktop is needed to reflect any metadata changes" statement.

Many times in the past I had columns added to or removed from the underlying source.

And as long as they were not explicitly referenced in any of Power Query steps or were used in DAX formulas or report visuals - I neither didn't have to refresh the Desktop nor did I get any errors in the service. Everything kept refreshing fine by scheduled refresh.

Can you please check this?

Thank you

Leonid_Kostin
Advocate I

Strange case. Same for me. Everything works perfect in Desktop but after I publish it to Power BI Online, it fails to refresh. I even deleted the original file (dateset + report). Haven't seen anything like this before

Vee
Regular Visitor

Hi,

I get the same error on a refresh.

I have a query that uses a pivoted column.

This columns happens to be a date.

The query also uses relative filtering on this date (in the next 2 weeks).

The date column changes based on this filter. and the column 6/13/2022 , 6/14/2022 are no longer part of the data set, but other days are added. 

The query starts by collexting a filtered dataset, then pivots the data, so why the error?

farid_0709
Frequent Visitor

Did any of you find the solution?

chiragppatel
Employee

Hi,

 

I am having same issue. 

 

Data source error: The '<pii>Column_Name_Goes_Here</pii>' column does not exist in the rowset.

 

Does anyone have fix of it?

 

Thanks

Leonid_Kostin
Advocate I

Hi @chiragppatel @farid_0709 @Vee 

 

for us we solved this by using the privacy level settings plus check / uncheck option below.

Please see it on my screenshot.

 

Leonid_Kostin_0-1655894575175.png

 

Let me know please if it helps you.

 

Regards,

 

Leonid Kostin

 

chiragppatel
Employee

Thanks @Leonid_Kostin .

 

I do not see this option. Can you share screenshot again along with where I can see this in portal?

Leonid_Kostin
Advocate I

Hi, @chiragppatel 

 

If you click "Settings" on the dataset and go to the "Data source credentials" and then click "Edit credentials", you can find a user, password, privacy levels and the checkbox. 

 

Hope it helps.