Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Unknown Result Code: Conflict

When trying to publish an update to a report, I get an error saying "Unknown Result Code: Conflict" 

This is a report currently in the workspace using live connect to a data model also in the same workspace.


I can publish this report to other workspaces fine, just get the error when trying to replace the old version.

Status: New
Community Support

hi  @mcm 

I have tested on my side, but not reproduce the error,

and I search for information about this error, but not find any useful information.


if you could upload this report in power bi service ->get data->files->local file ?


and if use other dataset create a new live connect report and publish it to see if it works well.






Frequent Visitor

Hi @mcm 

Recently, I am also facing the same issue while publishing a visual report that is connected live to the dataset residing in the workspace. Did you happen to find a solution?



Frequent Visitor

Hi @mcm ,


In my case, I needed to overwrite an existing visual report in the PowerBI workspace and was seeing the same error while publishing a new/modified version of it from my PowerBI Desktop (meaning, publishing a report with the same name). Overwriting a visual report in the workspace was never a problem for me earlier until today.

My solution: I first deleted the visual report that already existed in the PowerBI workspace, and then published it again from my PowerBI Desktop. It published successfully.


In case this helps you or someone else with the same problem in the future!


Helper II

Did you find a solution to this? This just started happening to me for a single report today. All other reports can still be overwritten by publishing. Deleting and re-publishing works, it also means that I have to re-set all permissions on the reports which I definetly don't want to do for all my reports in the future 😉

New Member

I had the same problem and discovered that I was trying to replace a copy from a dashboard on Power BI online.
Days before I deleted the original dashboard and kept only the copy published, so when a tried to replace it, the error happened.

Hope this helps

Frequent Visitor

This same problem has come up for me while using the June 2022 Feature Update. 
I have discovered a work-around:
from the Service, click Get Data, then under Create New Content - Files: click Get, then select your file from the options (Local File, SharePoint, etc), and it will publish with no issue. 

I experienced this problem 2 days ago. A reboot resolved my issues for about 36 hours, and now it is back for one pbix file. All of my pbix files are not affected.

Hope this workaround helps you while MS figures out what the problem is.

New Member

The same is happening to me right now. Is there any official solution to this? What is causing the error?