Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Unable to load the model - End Users Can't Access Certain App Content

I have published a report to a workspace in Power BI, and have shared the content as an app with several end users. For some reason, the below message appears when the end users try to access the content within the app:




None of the following worked in trying to resolve this issue:

-opening the report file in Power BI Desktop, clearing the cache and republishing to

-creating a new workspace, republishing the file to that workspace, then sharing that content as an app


I have created other reports and shared them as apps with the same end users in the organisation, and these apps have not had any issues. All users have Pro licenses, and I have never needed to manage the permissions of the specific datasets published to each workspace. When I look at manage permissions, all users have App, Reshare, Build permission.


When I encountered this issue before, I was able to fix it by creating a new blank Power BI Desktop file, copying across all of my queries from the existing file, rebuilding the data model and adding back all the visuals, then republishing the file.


As a temporary fix (and to avoid re-creating the Power BI file again), this time I have added all the users that I originally shared the app with as Admins on the underlying workspace. They are now able to see the app content, but as soon as I take the admin permission away, the same issue comes back.


Adding end users as Admins on the workspace is NOT an ideal solution. This appears to be a random problem and I would appreciate step-by-step guidance on how to resolve it (and prevent it from happening again in the future).


Status: New
Community Support

Hi @emarshall ,

Could not reproduce it entirely in my side as far as my test. Based on your description, sounds like it only happened on the special .pbix file.


You can try to add all the users as a single group and give this group access to visit this app to check whether it works.


Best Regards,
Community Support Team _ Yingjie Li

Advocate I


thanks for getting back to me.


I tried sharing via the security group but this did not have any effect. I have recreated this file and workspace several times and this is still a problem unless I make members admin on the workspace.

Advocate I



Hi Yingjie,


I have the same issue but now on a different workspace.



I published 5 different PBIX files to this workpace, and shared the associated 5 reports with end users via an app.


Originally I did this via a security group, however members received the above error. I then tried sharing this with individual users who were part of the security group but that didn't work either. The only way to resolve this problem was to make the end users admins on the workspace.


This really doesn't make sense. If I publish a PBIX file to a workspace and then share the app with individual emails or security groups, end users should be able to view and interact with the reports, with no exceptions.

If it helps with resolving this issue, originally I had 1-2 datasets within this workspace, then connected to these datasets using Power BI Desktop, created reports, then published the reports to the workspace, then shared the reports as an app (this was also originally the case in my original post). I later decided to delete all of this and have a separate PBIX file for each report. Perhaps this is some sort of caching bug in the web service where still expects reports to be linked to a data model that no longer exists?

Advocate I



I have investigated further and found that the issue was unassigned Row Level Security in the PBIX file. I have deleted the Row Level Security and republished the model and it appears to work now.


The error message I got was not very helpful in indicating that RLS was the problem.