AdriaanDP's avatar
AdriaanDP
Regular Visitor
8 years ago
Status:
Needs Info

Unable to connect: This data source cannot connect to all gateway instances of the cluster.

To whom can assist, I am having trouble to link to connect to the data gate way and getting the following message.

 

Unable to connect: This data source cannot connect to all gateway instances of the cluster. Please find more details below about specific errors for each gateway instance.Hide details

Activity ID:f208416b-d894-4441-89a1-72adae251583
Request ID:54c1550f-56c2-e389-b8bc-039704e7ab94
Cluster URI:https://wabi-europe-north-b-redirect.analysis.windows.net
Status code: 
Time:Mon Jan 08 2018 10:31:02 GMT+0200 (South Africa Standard Time)
Version:13.0.3495.333
  Gateway on endpoint '<ii>sb://wabi-europe-north-b-relay36.servicebus.windows.net/01da821d-2e09-44f7-b99f-cc25c57b776d/</ii>' is unreachable. 

10 Comments

  • v-jiascu-msft's avatar
    v-jiascu-msft
    Icon for Microsoft Employee rankMicrosoft Employee

    Hi AdriaanDP,

     

    This could be a temporary issue. 

    1. Where did you get this error message? 

    2. Did the Gateway work normally?

    3. Please try to delete the data source and add it back?

    4. What's the status of the cluster?

    Unable_to_connect_This_data_source_cannot_connect_to_all_gateway_instances_of_the_cluster

     

    Best Regards,

    Dale

  • AdriaanDP's avatar
    AdriaanDP
    Regular Visitor

     Hi v-jiascu-msft,

     

    This could be a temporary issue. 

    1. Where did you get this error message? on the dash you have on the response

    2. Did the Gateway work normally? Yes

    3. Please try to delete the data source and add it back? It does not allow me to add back the source

    4. What's the status of the cluster? Where do I see this

     

    Best regards

  • v-jiascu-msft's avatar
    v-jiascu-msft
    Icon for Microsoft Employee rankMicrosoft Employee

    Hi AdriaanDP,

     

    You can see the status of Gateway cluster in the manage gateway settings. And in the computer which you installed the gateway.

    Unable_to_connect_This_data_source_cannot_connect_to_all_gateway_instances_of_the_cluster2

     

    Best Regards,

    Dale

  • AdriaanDP's avatar
    AdriaanDP
    Regular Visitor

     Hi @v-jiascu-msft,

     

    Thanks, it seems that the reinstallation of the gateway work. However since then I have received a new error which I posted in my new post.

     

    Not sure if you can help with the table refresh issue in my new post.

     

    Best regards

     

  • DeeptiG's avatar
    DeeptiG
    Regular Visitor

    I came across such an issue twice. Gateway reinstallation can solve this but no need to reinstall it.

    This issue can be due to incorrect credential inputs (like If password is recently updated) under Gateway Cluster Settings. For me, I recently changed my password for logged in account but I did not update it for gateway settings. So please check/update for fields - contact information and password under Gateway Cluster settings.

     

  • Hi All,

     

    I came across the same problem and all you need to do is stop the On-Premises Data Gateaway Services and restart them again.

  • jakesm234 - Right on! Worked for me.

     

    1) Ctrl + Alt + Del to open the Task Manager

    2) Click the "Services" tab

    3) Find "On-premise data gateway service" in the list (sort by name or description, mine showed up with that name in the "Description" field (name value was "PBIEgwService")

    4) Right click and click "Start" (mine was not running)

     

    Thank you!

  • Anonymous's avatar
    Anonymous
    Not applicable

    Hi ,

     I really need help on the below issue.

     

    DATABASE: SAP HANA

     

    Unable to connect: We encountered an error while trying to connect to. Details: "We could not register this data source for any gateway instances within this cluster. Please find more details below about specific errors for each gateway instance."Hide details

    Activity ID:

    f71653b1-a88e-448d-9b04-5e7aa4b14855

    Request ID:

    b660e877-8bff-3cd5-0f58-7884b9c88235

    Cluster URI:

    https://wabi-north-europe-redirect.analysis.windows.net/

    Status code:

    400

    Error Code:

    DMTS_PublishDatasourceToClusterErrorCode

    Time:

    Sat Jun 06 2020 16:40:04 GMT+0530 (India Standard Time)

    Service version:

    13.0.13524.220

    Client version:

    2006.1.01321-train

     

    PBGWTEGW01:

    Invalid connection credentials.

    Underlying error code:

    -2147467259

    Underlying error message:

    [SAP AG][LIBODBCHDB DLL][HDBODBC] Communication link failure;-10709 Connection failed (RTE:[300012] Cannot create SSL engine: The certificate chain was issued by an authority that is not trusted. (HANA DB SERVER))

     

    Any one encountered similar issue.

     
     
  • Anonymous  I'm facing the same error, did you have any luck solvig it?

    I'll appreciate the support.

     

    Regards!