cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to configure gateway connections for dataset

Hi,

I am unable to configure gateway connections for dataset for a pbix report uploaded. I have created data source connections prior to uploading the file. All the 23 data sources are on-prem.

When I tried to apply the gateway connections (all have green check marks), I got this error message:

Link0978_0-1670952960704.png

I also noticed this banner. The dataset does not have any cloud data souces:

Link0978_1-1670953073426.png

 

 

Edit:

@v-yetao1-msft 

I originally just uploaded the pbix file to the web portal. The file was built using the Power BI Desktop RS Jan 2022 version. Then I tried to open the pbix file in the RS Jan 2022 and published to our P1 capacity-backed workspace. The issue persists.

 

Then I opened the file in Power BI Desktop Oct 2022 for powerbi.com version. I saved the file and published it again. The issue persists.

 

Some of the data source connections are also used by other reports without an issue. The other connections were created just for this report.

The connections are consisted of SQL servers and file shares.

 

We have 2 windows 2016 VMs in a cluster to host the on-prem gateway. Version Aug 2022.

 

 

 

Status: Delivered

Hi @Link0978 

This issue has been fixed , I will change it to "Delivered" .

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
v-yetao1-msft
Community Support
Status changed to: Accepted

Hi @Link0978 

It's a known issue , the ID is 356136950 . If there is any progress, I will come back to update .

 

Best Regards,
Community Support Team _ Ailsa Tao

ehernanz
Regular Visitor

I have the same problem since last thursday too.

ryanjohannes
Regular Visitor

We're experiencing as well. 

JasonBreedlove
Frequent Visitor

We are having this problem as well

IrkenCR
Microsoft

Hello,

 

The product group has the fix, and they are planning to roll out soon. I will let you know the ETA as we get news from the Product Group.

 

Thank you, 

Rendip
Regular Visitor

Hello guys,

 

We're experiencing it as well, but we tried to duplicate our gateways with different names and try to add to each file a different name gateway and boom, works fine.
While MS try to fix this error, this is an exit for this issue.

 

GTW.PNG
Best regards,
Rendip

felipe_souza
Frequent Visitor

Top. I applied the same configuration idea, creating 6 new names, and it worked correctly.
We await a definitive solution from Microsoft.
Thanks @Rendip 

IrkenCR
Microsoft

Hello everyone,

 

The ETA for the fix is 12/26. The support page is now updated with the fix ETA. 

 

IrkenCR_1-1671719870386.png

 

Workaround: User needs to create a separate datasource for each path in their dataset, bind each path to a different datasource and hit apply. This will succeed.

 

Example:

When you select "Xlxs Folder" for both paths you will run into failures

 

IrkenCR_3-1671720008235.png

 

But if you create a new datasource for each path and bind to that, it should succeed.

IrkenCR_4-1671720031530.png

 

Thanks,

DhirenPatel
Regular Visitor

Hi All,

 

Work around which worked for me

 

1. Publish The file with correct name to required workspaces unsure you only use one datasource. Set up the refresh.

2. Add remaining data sources and re-publish. 

felipe_souza
Frequent Visitor

Hi!

@IrkenCR 

 

Is the fix not yet available from Microsoft? I checked in the Gateway download area and there is still version 3000.154.3 of 12/16/2022. Update the status please.