Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

'Test as Role' not working with pagainted report published

This is new and probably a bug that hopefully gets fixed soon but when I publish a paginated report, connected to a power bi dataset, the 'Test as Role' functionality (for RLS) doesn't work. 

I get this error. Needless to say, I am the owner of the dataset and the reports.

MURTAZA_0-1695047487878.png

 

When I deleted the paginated report, everything seemed to be working as expected. Even our existing reports are acting similarly all of a sudden. Is anyone experiencing this? 

Status: Needs Info

Hi @MURTAZA ,

 

For the time being there is no feedback from other users experiencing similar issues to you, I did a simple test but it didn't reproduce your situation.
Is this problem occurring in a specific report or workspace? Can other users in your organization also reproduce this issue?

 

Best regards.
Community Support Team_Caitlyn

 

Comments
v-xiaoyan-msft
Community Support
Status changed to: Needs Info

Hi @MURTAZA ,

 

For the time being there is no feedback from other users experiencing similar issues to you, I did a simple test but it didn't reproduce your situation.
Is this problem occurring in a specific report or workspace? Can other users in your organization also reproduce this issue?

 

Best regards.
Community Support Team_Caitlyn

 

HayesChow
Regular Visitor

I can get the the test as role functionality to work in two other workspaces, one with a paginated report and one without. It also works for me on another dataset in the same workspace as the one mentioned above. 

 

Other things to try:

  • Add same paginated report to the working dataset in the same workspace.
  • Add a new paginated report to the working dataset in the same workspace.
  • Remove all users from rls role. Then add one back to test.
  • Remove role entirely from dataset in question. And then add it back again.

 

Cheers,

Hayes

MURTAZA
Resolver I


@v-xiaoyan-msft 
So I did some more tests and discovered that this only happens to the dataset containing incremental refresh set up. Does this help?

DirkS
Frequent Visitor

Hi everyone,

 

I have the same problem for one of my reports. I am admin and it used to work for me for several years. Now it doesn't for several weeks...

I do not use incremental refresh. So that seems not the problem. Also: publishing the report with another name works but I don't want to do that because a lot of users have a link on the original report.

 

Seems to be an issue in the PowerBi service.


Btw here is another case: https://community.fabric.microsoft.com/t5/Issues/Test-as-Role-not-working-properly/idc-p/3461340

 

Best regards

Dirk

MURTAZA
Resolver I

I tried the steps Dirk mentioned. 

 

Renamed my dataset,

published to shared workspace

Linked to this dataset and published paginated report

the 'Test as Role' feature does not work. 

 

If I delete the paginated report, 'Test as Role' works fine. 

 

So renaming and republishing didn't work for me, unfortunately.