Showing results for 
Search instead for 
Did you mean: 

Sync Slicers is buggy - still filters even after un-selecting

Sync Slicers is buggy in PowerBI Desktop (latest Oct 2018 release) - if you stop syncing, the slicer often still filters the pages it was applied to, even if you untick the boxes on the Sync Slicers properties - very frustrating. If you completely delete the synced slicer, it still applies (which is even worse)!


Further details at and


You can work around this (and prove its effect) by copying the visuals to another page tab where they will work (fortunately). This demonstrates the fact that there's still a hidden slicer on the page. This is a serious bug, wasting time and putting people off. Should be easy to test and fix at HQ though 🙂 




Status: Accepted
Advocate I

This issue still exists, with latest version of power bi desktop. No way is this a feature, clearly a bug!


I have removed the slicers from my entire report, no slicers anywhere, and yet it still syncs behind the scene, on all sheets that they used to be synced at. My file is basically corrupt now as i can't remove the "hidden slicer".


When I add a new page and add some data, we can see all data comes through. But on any sheet where these slicers used to be synced to, despite no more slicer at all, the data remains filtered. Useless.

Frequent Visitor

This bug still exists, not sure this hasn;t been fixed as yet. Syncs can become 'stuck' in the report if not careful, very poor implementation. Though I imagine MS are relucant to repair the issue as it'll probably mean rewiring how sync/filters work at a core level. The implementation was just poorly coded at the start it seems?

Frequent Visitor



 This error still exists, I have found a way to remove this error. You have to select the slicer that filters the sheet and you have to go to View->Sync slicer settings. Again, set it as visible on that sheet where the error is. Then go to the sheet and deselect all filters in the slicer. Then clear all selections for this slicer. It helped me:)