Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Slicer converts to single select after publishing

I created a report with multiple slicers , all having multiple select options. The report works fine in desktop application. However, when I publish the report, one of the slicer gets converted to single select slicer. How do I resolve this?

Status: Investigating

Could not reproduce it in my side as far as my test, when I have created multiple-selection slicers in a report and publish it to Power BI Service, all of them work fine.

vyingjl_0-1661842467904.png

Desktop version: 2.108.825.0 64-bit (August 2022)

 

Perhaps you can try to republish this report to different workspaces to check it again, if it still has the same issue, you can share more details about it like the desktop version or some screenshots, gif etc.

 

Best Regards,
Community Support Team _ Yingjie Li

 

Comments
v-yingjl
Community Support
Status changed to: Investigating

Could not reproduce it in my side as far as my test, when I have created multiple-selection slicers in a report and publish it to Power BI Service, all of them work fine.

vyingjl_0-1661842467904.png

Desktop version: 2.108.825.0 64-bit (August 2022)

 

Perhaps you can try to republish this report to different workspaces to check it again, if it still has the same issue, you can share more details about it like the desktop version or some screenshots, gif etc.

 

Best Regards,
Community Support Team _ Yingjie Li

 

kesua
New Member

I had the same problem and solved it.

 

How to replicate it: Publish report to PBI Service with multi-select slicers. Then edit it directly in PBI Service to single-select slicers and save it there. Then publish new version from desktop (again with multi-select). Slicer settings from desktop gets automatically updated to the status you made in PBI Service without any notice. Problem is that when you try to change it to multi-select again directly in PBI service, nothing happens and it stays as single-select. IMHO this is a bug.

 

Solution is to delete the report in PBI Service and publish it there again from scratch. Then it works as expected.