Schedule refresh of a dataflow from a datalake failed (Credential is not stored)
Hi,
I try to schedule an automatic refresh of my dataflow which is conected to a datalake Storage Gen 2. When I refresh it "on demand", it works properly but the automatic refresh fail with the following error:
"Data source credentials are missing or invalid. Please update the credentials for AzureDataLakeStorage in dataflows settings page and try again"
Each time I'm going to the parameters of the dataflow, I got this message in identification information for the datasource:
I update identification information by conecting my account but it's like if my account's parameters were not stored ...
When I put my credential, I got this (it seems to be registered):
And about one hour after, I got:
Can you help please ?
5 Comments
- v-cazheng-msft
Community Support
Status changed:NewtoInvestigatingHi frenchphil
It may because the lifetime of Azure AD passthrough token is one hour. May I know whether you have used gateway for this data source? If you configure gateway for it, will you get same issue?
Best Regards,
Community Support Team _ Caiyun
- frenchphilFrequent Visitor
I don't use any gateway to access this data source. The Datalake I access to is not mine (it's administrated by a third company on Azure and they give me rights to access it) and I can't install a gateway on their architecture ...
Best regards
- frenchphilFrequent Visitor
Have you got more information about this issue ? Is it mandatory to configure a gateway to refresh a dataflow from a datalake?
I am blocked in my deployment at this point ....
Thanks for your help ...
Best regards
- v-cazheng-msft
Community Support
Hi frenchphil
Thanks for your reply! I understand. If it is urgent for you, please consider creating a support ticket in Power BI support if you are a Pro user. Then, there will be a support engineer help you on this issue. For how to create a support ticket, please refer to this blog.
Best Regards,
Community Support Team _ Caiyun
- frenchphilFrequent Visitor
Thank you v-cazheng-msft
I am novice in the community and I thought this part of the site was already linked with Microsoft support ...
I have a Pro Licence but it doesn't let me create a new support issue. I don't know if I have to suscribe a special "Support plan" or if I have to activate something somewhere ...
Message:
"Votre compte ne dispose pas des autorisations nécessaires pour créer des demandes de prise en charge pour ce service. Essayez de sélectionner un autre plan de support."
Any idea ?