SAP HANA - Kerberos error when refreshing in PBI Service
Last night, we started getting errors refreshing SAP HANA datasets via the gateway. We use the SSO advanced option (SSO for DQ and Import). Not using SSO works fine. The failures started immediately after getting an alert that there was a problem with the PBI service. Did anything change last night?
{"error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","pbi.error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","parameters":{},"details":[{"code":"DM_ErrorDetailNameCode_UnderlyingErrorCode","detail":{"type":1,"value":"-2147467259"}},{"code":"DM_ErrorDetailNameCode_UnderlyingErrorMessage","detail":{"type":1,"value":"<pi>ODBC: ERROR [08S01] [SAP AG][LIBODBCHDB DLL][HDBODBC] Communication link failure;-10709 Connection failed (RTE:[-1] Kerberos error. Major: \"Miscellaneous failure [851968]\", minor: \"The logon attempt failed\r\n [2148074252/-2146893044]\" (SERVER:PORT HIDDEN))</pi>"}},{"code":"DM_ErrorDetailNameCode_UnderlyingHResult","detail":{"type":1,"value":"-2147467259"}},{"code":"Microsoft.Data.Mashup.ValueError.DataSourceKind","detail":{"type":1,"value":"SapHana"}},{"code":"Microsoft.Data.Mashup.ValueError.DataSourcePath","detail":{"type":1,"value":"SERVER:PORT HIDDEN"}},{"code":"Microsoft.Data.Mashup.ValueError.OdbcErrors","detail":{"type":1,"value":"#table({\"SQLState\", \"NativeError\", \"Message\"}, {})"}},{"code":"Microsoft.Data.Mashup.ValueError.Reason","detail":{"type":1,"value":"DataSource.Error"}}],"exceptionCulprit":1}}} Table: Query1.
3 Comments
- v-robertq-msft
Community Support
Status changed:NewtoInvestigatingHi,
If you want to get a solution for this kind of refresh problem as soon as possible, I suggest you to open a support ticket to get direct help from the technical support team of Microsoft.
https://powerbi.microsoft.com/en-us/support/
Thank you very much!
Best Regards,
Community Support Team _Robert Qin
- AnonymousNot applicable
Hello,
I am also facing the same error in Power BI desktop while using SSO with HANA. Did we have any solution for this?
Regards.
- reevetRegular Visitor
A support ticket was opened. The issue was a security update released by Microsoft that killed SSO for SAP HANA. The solution was to patch all gateway servers and domain controllers with the latest patch release.