Report service return Error when refreshing with incremantl refresh
It is currently not possible for me to refresh reports on the report service.
The error i'm getting is: The command has been canceled.. The exception was raised by the IDbCommand interface.
few info:
* This started on Saturday 1st december 2018
* Refresh works fine on desktop app
* It only affects report with incremental refresh ON
* I tried to rename the report and reupload but same error occurs
* When I disable the incremental refresh, report service works fine (but unacceptable for production)
Can you help. This is affecting the reports I have in prodcution and it is pretty urgent for me to fix.
13 Comments
- AnonymousNot applicable
teripaquitinho,
Do you mean that it fails to refresh report in Power BI Service when you enable incremental refresh option? If so, could you please post the full error message that including request id and cluster url?
Also do you have Power BI premium license ? What is your data source? And we will appreciate it if you can share Power Query code here. Do mask sensitive information when you upload image or share power query code.
Regards,
Lydia - AnonymousNot applicable
- teripaquitinhoRegular Visitor
Yes, I have a Power BI premium license and the very same report was working until friday. My data source is Redshift.
And yes, it was failing when i tried to refresh report in Power BI Service with enabled incremental refresh option. However, it now fails also when incremental refresh is off.The error i'm getting now is different from yesterday's. this is what i'm getting now
ODBC: ERROR [IM003] Specified driver could not be loaded due to system error 126: The specified module could not be found. (Simba Amazon Redshift ODBC Driver, D:\SvcFab\_App\analysisserver.backendapptype_App12480\analysisserver.backend.servicepackage.Code.2018.11.4.37\workloads\AS.2018.11.4.204\MDataEngine\ODBC Drivers\Simba Amazon Redshift ODBC Driver\AmazonRedshiftODBC_sb64.dll).. The exception was raised by the IDbCommand interface.
It seems there is a problem with Redshift (see here https://community.powerbi.com/t5/Service/Direct-Query-connectivity-issues-with-Redshift-in-the-last-few/m-p/576983/highlight/true) - AnonymousNot applicable
We are experiencing the same issue -- is there any timeline for when this will be resolved?
- kevhav
Continued Contributor
This also started happening to us, several hours ago.
We have Power BI Premium...the dataset has incremental refresh policies...and our data source is Amazon Redshift.
- kevhav
Continued Contributor
Full error details:
Data source error:
ODBC: ERROR [IM003] Specified driver could not be loaded due to system error 126: The specified module could not be found. (Simba Amazon Redshift ODBC Driver, D:\SvcFab\_App\analysisserver.backendapptype_App3262\analysisserver.backend.servicepackage.Code.2018.11.4.37\workloads\AS.2018.11.4.204\MDataEngine\ODBC Drivers\Simba Amazon Redshift ODBC Driver\AmazonRedshiftODBC_sb64.dll).. The exception was raised by the IDbCommand interface. Table: table_x.
Cluster URI:
WABI-WEST-US-redirect.analysis.windows.netActivity ID:
3d2c4308-bdf1-445d-86db-637687e1c704Request ID:
b899282b-ce32-4af3-9873-a0256317cb45Time:
2018-12-04 14:12:01Z - kevhav
Continued Contributor
This appears to be fixed for us, since ~11:00 p.m. last night (Pacific).
- teripaquitinhoRegular Visitor
kevhavhow come? i'm still experiencing the same error. did the error just disappear or did you have to do something about it?
- kevhav
Continued Contributor
I did not do anything about it. It seemed to fix itself.
- teripaquitinhoRegular Visitor
let's wait and see then