Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Relationship Lines Missing in Model Viewer in Version 2.119.701.0

All the relationship lines are missing from the model view.  All graphical manipulation of the model fails.  Adding new tables/datasources fail.  A new version needs to be released immediately.  It appears that version 2.119.666.0 doesn't have that problem.  These versions are so new that they're not even documented on the Microsoft site.  😞

 

Status: Accepted

Hi @cperuski 

It’s a known issue . The engineers are actively working on this issue and I will come back with an update if there is any progress.

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
JamesYoungTri
Regular Visitor

I just updated and (2.119.986.0 64-bit) and the behavior is better, but some of the problems persist.

 

- Detault view still showed no relatiionships, and like before the relationship lines would render as I moved each table in the model. 

- I am now seeing some of the tables which had previously been stacked in the top left, I am able to move them and their relationship lines render when they are moved.

- There are still 2-3 of which are stacked in the top left, cannot be moved, and do not show relationship lines despite the fact that relationships exist.

 

Is anyone else seeing this as a partial solve?

Anonymous
Not applicable

Yes, partial solve but still many issues. I have all problems @JamesYoungTri mentioned and in addition there are some tables where the relationship lines stuck and don't move with the table (like disconnected lines).

 

Still can't move tables from upper left corner.

Pat_msft
Employee

Thanks for the feedback. This issue should now be considered fixed. Here's some context for those still experiencing issues. 

Tables still stuck in the top-left. This is a state that you could only get into due to the now-fixed bug. We've filed a new bug for this state and it's under investigation. You can get around it locally one of two ways. 1) "Reset Layout" in the bottom right corner, in the status bar. This will lose your current layout, and reset all tables to default where they will be draggable. 2) You can remove and re-add the problematic tables from the model. It's understood that these are not great options, but until the new bug is fixed, these are the options.

 

Relationship lines overlapping each other or other tables. This is by design due to usage of more modern and faster layout of relationship lines. Scenarios where this happens should be limited to models with either a large number of tables, or very specific locations of the tables and their relationship(s) [in this second case, moving the tables slightly should resolve the issue]. If these new layout choices are not ideal, please file a new idea on the powerbi / fabric ideas site. 

Pat_msft
Employee

@Anonymous Are the disconnected relationships ones that are connected to tables stuck in the top-left? If so can you try one of the mentioned approaches and see if it is resolved that way?

Anonymous
Not applicable

@Pat_msft thank you for the instructions. I have now deleted all relationships and created them completely new. I recommend you all here to upload your file to "my workspace" and open the data model editor in the service. There you will be able to see the relationship lines.

 

With this help, I created alle relationships again and it seems to work BUT still have the problem when adding new tables they will stuck in the upper left corner.

Creating relationships for this stucked table in the 'All tables' page will lead to stucked relationship lines between all other tables.

But you can create relationships and move the stucked table if you do it in a separate model layout view but seems like the 'All tables' page will not be reachable anymore after doing so...

After deleting this new (stucked) table, everything will be fine again.

Suraphan_TH
Regular Visitor

Updated to version 2.119.986.0 but still the same issues:

- no relationship lines appear when opened (until move each table but the line are disorganized)

- still have one table stuck on the top left corner

lcs26481
Frequent Visitor

I started seeing this last week. In addition to the lines being missing I had a problem of not being all to go back to the Main tab (Sheet 1 if not renamed) after creating a few tabs with a single table and all it's related tables. I don't know if that is the expected behaviour, but I would hope not. I didn't create other tabs for every single element so I need the main tab (I named it All Tables). My model is very large with lots of moving parts. 

 

Edit: FOr reference I had this version installed before reinstalling with the June version below: Version: 2.119.986.0 64-bit (July 2023)

 

I just reinstalled Version: 2.118.1063.0 32-bit (June 2023) and I am now able to see the lines again. Looking to have a fix soon so I can keep up to date on the releases. 

lcs26481
Frequent Visitor

@Suraphan_TH Try June 23 version (2.118.1063.0 32-bit) since it just worked for me and it's only 1 release behind. https://learn.microsoft.com/en-us/power-bi/fundamentals/desktop-latest-update-archive?tabs=powerbi-d...

 

Rafman888
New Member

@Anonymous , @Pat_msft 

thanks Alma7!

Quick fix for me:

I can confirm that reducing number of tables to <51 has resulted in "unstucking" tables overlapped in top left corner of model view AND relationship lines are back.

Re: Relationship Lines Missing in Model Viewer in Version 2.119.701.0 

  

Tess
Regular Visitor

abut 2-3 weeks ago, exact same thing as @Anonymous, and then beginning about a week ago, all relationship lines disappeard. CurretVerion 2.119.986.0 64-bit (July, 2023).

Please fix it ASAP